• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' the posts that you read.

Aggravating issue....revisited...


rusty ol ranger

2.9L Mafia-Don
Supporting Member
Joined
Sep 22, 2007
Messages
6,912
Reaction score
2,045
Points
113
Location
Michigan
Vehicle Year
1987
Make / Model
Ford
Engine Type
2.9 V6
Engine Size
177 CID
Transmission
Manual
2WD / 4WD
2WD
My credo
A legend to the old man, a hero to the child...
Heres the original thread....so i dont have to type the whole thing again...


Anyways....one suggestion that came up was the fuel filter, which i did change but it was when it still had the old fuel tank in it so who knows what got sucked up into it.

Well when i changed the filter before the line was stuck on the filter and when i pulled it all came apart.

So i had my mechanic put a new line on....and he used this...

20200912_142911.jpg


Could that 90* bend be causing the issues im having?
 


Rock Auto 5% Discount Code: 4FF3E9EEA14805 Expires: October 1st, 2020

ericbphoto

Old Redneck just wingin' it.
Forum Moderator
Supporting Member
U.S. Military - Veteran
TRS 20th Anniversary
Joined
Feb 7, 2016
Messages
6,367
Reaction score
3,321
Points
113
Age
56
Location
Wellford, SC
Vehicle Year
1993
Make / Model
Ford Ranger
Engine Type
3.0 V6
Engine Size
3.0L
Transmission
Manual
2WD / 4WD
4WD
Total Lift
6"
Tire Size
35"
My credo
In theory, theory and practice are the same. In practice, they are different.
It shouldn't.
 

PetroleumJunkie412

2.9 Mafia
Supporting Member
TRS 20th Anniversary
Joined
Oct 31, 2018
Messages
6,121
Reaction score
4,368
Points
113
Location
Pittsburgh, PA
Vehicle Year
1988
Make / Model
Ranger
Engine Size
2.9l Trinity
Transmission
Manual
2WD / 4WD
4WD
My credo
Give 'yer balls a tug. Fight me.
Odd question.... whens the last time you tossed a tfi at it?

Also, still running the ecm i sent your way?
 

rusty ol ranger

2.9L Mafia-Don
Supporting Member
Joined
Sep 22, 2007
Messages
6,912
Reaction score
2,045
Points
113
Location
Michigan
Vehicle Year
1987
Make / Model
Ford
Engine Type
2.9 V6
Engine Size
177 CID
Transmission
Manual
2WD / 4WD
2WD
My credo
A legend to the old man, a hero to the child...
Odd question.... whens the last time you tossed a tfi at it?

Also, still running the ecm i sent your way?
When i did the distributor....so a year ago or so.

....and yes its got your ecm in it.
 

JerryC

Member
Joined
Apr 10, 2014
Messages
206
Reaction score
17
Points
18
Location
Tennessee
Vehicle Year
1988
Make / Model
Ford
Engine Size
2.9
Transmission
Automatic
I was reading the original post and this stood out, you said if it turn it off it runs ok for a couple of minutes.
So maybe it runs fine off the open loop ECM map but when it goes closed loop you have the problem. That would point to a sensor issue.
 

rusty ol ranger

2.9L Mafia-Don
Supporting Member
Joined
Sep 22, 2007
Messages
6,912
Reaction score
2,045
Points
113
Location
Michigan
Vehicle Year
1987
Make / Model
Ford
Engine Type
2.9 V6
Engine Size
177 CID
Transmission
Manual
2WD / 4WD
2WD
My credo
A legend to the old man, a hero to the child...
I was reading the original post and this stood out, you said if it turn it off it runs ok for a couple of minutes.
So maybe it runs fine off the open loop ECM map but when it goes closed loop you have the problem. That would point to a sensor issue.
Every sensor besides the TPS and MAP is new. Its getting 21-22mpg so i dont think its an O2 or something dicked up. After talking to @PetroleumJunkie412 the other day i realized that it didnt do this before i timed it and deleted the EGR.

So im gonna recheck the timing and properly block off EGR before i go to crazy into it.
 


Top