• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

A/c not working, switches good, refrigerant full. Can anyone solve the unsolvable?


surfinhound

New Member
Joined
Mar 23, 2012
Messages
6
Reaction score
0
Points
0
Vehicle Year
1998
Make / Model
ford
Transmission
Manual
I have a 1998 ford ranger with the 2.5l engine. Very amazing vehicle but the a/c does not work. Ive had some very smart a/c people tell me to jumper the pins in the switches and if the compressor kicks on then my switches are bad but i have jumpered the switches and still the compressor wont run. The only way i can get it to run but it stays constantly on is to jumper two pins in the power distribution box. If i pull out the a/c relay and jumper pins 1 and 3 which are the two top pins the a/c compressor will kick on whether the switch inside the cab is on or not. Can anyone provide some advice on how to solve this? Many have tried but no one seems to have the

MAJOR UPDATE: I checked the junkyard and found three 1998 ford rangers with 2.5's. Now follow me on this. Behind the dash where the switch is to control whether or not the a/c is on max or defrost or on foot etc., if you remove the cd player panel and such and observe this switch. It will have on the top of it, a four pin power plug going into the switch with a black ground wire and a red power wire. NOTE In all 3 junkyard vehicles there is a gray wire with yellow stripe in the 3rd pin and a solid purple in the fourth pin. So the wires behind the switch are red, black, gray with yellow stripe, and solid purple. My vehicle has no gray with yellow stripe or solid purple. Its simply just missing these wires, i only have the red and the black and the other two pins are empty. When i traced the two at the junkyard the gray with yellow stripe went to the fuse box to the left of the steering wheel and the purple went outside to the power distribution box. Now i tried in my vehicle to trace these two wires i am missing. I traced as far back as my hand would reach behind where the cd player goes and cant find these two wires!!!!! Any advice? Any at all?

Sorry for reposting this statement on the bottom, im kinda new to these forums.
 
Last edited:


Rock Auto 5% Discount Code: F9A1A579ACFAD1: October 1st, 2021

exbass94

Well-Known Member
Joined
Aug 6, 2007
Messages
3,340
Reaction score
37
Points
48
Age
33
Location
Guilford, CT
Vehicle Year
2006, 1994
Make / Model
Ford
Engine Size
4.0 SOHC, 4.0 OHV
Transmission
Automatic
When you say you tried jumpering the switches, you mean you jumpered the wire harness that connects to the switch, not the pins on the switch itself, right?
 

kryptonitecb

New Member
U.S. Military - Veteran
Joined
Dec 5, 2011
Messages
1,313
Reaction score
17
Points
0
Location
Fort Worth, TX
Vehicle Year
1994
Make / Model
Ford
Engine Size
4.0
Transmission
Manual
Sounds like you answered your own question. If you jumped the relay and makes something work then that relay/sensor is bad.

Sent from road while ignoring traffic
 

surfinhound

New Member
Joined
Mar 23, 2012
Messages
6
Reaction score
0
Points
0
Vehicle Year
1998
Make / Model
ford
Transmission
Manual
MAJOR UPDATE: I checked the junkyard and found three 1998 ford rangers with 2.5's. Now follow me on this. Behind the dash where the switch is to control whether or not the a/c is on max or defrost or on foot etc., if you remove the cd player panel and such and observe this switch. It will have on the top of it, a four pin power plug going into the switch with a black ground wire and a red power wire. NOTE In all 3 junkyard vehicles there is a gray wire with yellow stripe in the 3rd pin and a solid purple in the fourth pin. So the wires behind the switch are red, black, gray with yellow stripe, and solid purple. My vehicle has no gray with yellow stripe or solid purple. Its simply just missing these wires, i only have the red and the black and the other two pins are empty. When i traced the two at the junkyard the gray with yellow stripe went to the fuse box to the left of the steering wheel and the purple went outside to the power distribution box. Now i tried in my vehicle to trace these two wires i am missing. I traced as far back as my hand would reach behind where the cd player goes and cant find these two wires!!!!! Any advice? Any at all?
 

surfinhound

New Member
Joined
Mar 23, 2012
Messages
6
Reaction score
0
Points
0
Vehicle Year
1998
Make / Model
ford
Transmission
Manual
Can anyone help me?
 

killj0y

New Member
Supporting Member
Joined
Mar 12, 2011
Messages
1,531
Reaction score
11
Points
0
Location
Edinburg, TX
Vehicle Year
1996
Make / Model
Ford
Engine Size
2.3l 4 Banger
Transmission
Manual
My credo
Fix it till its broke!
They are missing all together? I doubt anyone would rip them out entirely...you sure that's the ac relay?
 

surfinhound

New Member
Joined
Mar 23, 2012
Messages
6
Reaction score
0
Points
0
Vehicle Year
1998
Make / Model
ford
Transmission
Manual
ya 100% check any other vehicle even of other years and theirs 4 wires there. Not on mine though. A 4 pin connector with only a red and black in it. Can you say confusing
 


Top