• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

99 ranger trans issue please help


koths211

New Member
Joined
Apr 21, 2013
Messages
25
Reaction score
0
Points
0
Vehicle Year
89,95,99
Make / Model
ranger x3
Engine Size
2.9l,4.0,2.3,3.0
Transmission
Automatic
so I have a 99 ranger...3.0 flex fuel, ext.cab, xlt, 2wd.

I blew the motor (3.0)...
put different 3.0 (from 2001 truck I think) engine in truck...
everything bolted right up...no issues...
put original trans back in...truck wouldn't move..
bought different transmission...(from 2000 truck I think)
truck still wont move...

ive read online that from 2000 thru 2001 the transmissions changed from 4r44e to 5r44e...idk which trans is in the truck...it starts right up and runs great but absolutely will not move in any gear.

what im getting at is if the trans wont work in the truck due to the computer? any ideas on what to do would be greatly appreciated...

the engine works....so its compatible with the computer so its gotta be the trans not computing....im thinking about trying a computer from an 01 ranger and hoping for the best....:icon_confused::icon_confused::icon_confused::dunno:
 


Rock Auto 5% Discount Code: F9A1A579ACFAD1: October 1st, 2021

snake

New Member
Joined
Aug 6, 2007
Messages
1,388
Reaction score
4
Points
0
Location
canyon lake tx
Vehicle Year
2011
Make / Model
Ford
Engine Size
3.5
Transmission
Automatic
Silly questions, but you did bolt the converter to the flywheel, correct? It is full of fluid? All electrical connections connected? Obvious stuff, but for two trannys to do the same thing something is way wrong. If the original was working when you took it apart it should work when you put it back in. Also, could you spin the converter freely when the bellhousing was bolted tight to the engine before bolting up the converter? It should be loose or the converter wasn't fully seated in the tranny. You probably knew all this already... let us know what you find out I'd love to know what it is.
 

koths211

New Member
Joined
Apr 21, 2013
Messages
25
Reaction score
0
Points
0
Vehicle Year
89,95,99
Make / Model
ranger x3
Engine Size
2.9l,4.0,2.3,3.0
Transmission
Automatic
snake...yeah I made sure all that stuff was right and full of fluid and what not...when I put the original trans on first I must have done something wrong because some small pieces of a brass ring were broken and sitting inside the bell housing...the second one went right in perfect...everything went together nice and smooth...I honestly think I have the wrong transmission in there tho....idk...u have any other thoughts???
 


Top