• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

96 with code P1443 help needed


98v70dad

Member
Joined
Oct 8, 2017
Messages
265
Reaction score
18
Points
18
Location
GA
Vehicle Year
1996
Make / Model
Ford
Engine Size
3.0L
Transmission
Automatic
2WD / 4WD
2WD
My dad gave me his 96 ranger XLT with 49,000 miles on it. He has had trouble code P1443 since 1998 but he lives in an area with no emission check so he let it ride. His fix was a piece of black electrical tape over the check engine light.

Anyhow, I'm in Atlanta and I can't register the truck in Georgia until I fix this. I have troubleshot evap systems before and know what a pain they can be to diagnose. My 20 year old volvo has had this same problem - major PITA.

Since the code showed up when the truck was only 2 years old I'm thinking that may be a hint. The code indicates its an evap system control valve but I know that it could also be a gas cap or a leak.

Can anyone tell me where that valve is located and what the most likely source of the problem could be considering that it showed up when the truck was nearly new.
 


Rock Auto 5% Discount Code: 7FA902352B4C01: April 5th, 2021

RonD

Well-Known Member
Joined
Jun 2, 2012
Messages
18,517
Reaction score
2,993
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Some good info in this thread: http://www.therangerstation.com/forums/showthread.php?t=70038

The codes the computer does NOT choose to use are as important as the one it does use.

OBD2 codes here: http://www.therangerstation.com/tech_library/OBD-II_codes.shtml

Computer used P1443 and not :
P1440 Purge Valve Stuck Open
P1441 ELC System 1
P1442 Evaporative Emission System Control Leak Detected
(P1443 Evaporative Emission System Control Valve (low/no flow))
P1444 Evaporative Emission System Purge Flow Sensor Circuit Low Input
P1445 Purge Flow Sensor Circuit High Input
P1446 Evaporative Vacuum Solenoid Circuit
P1447 ELC System Closure Valve Flow
P1448 ELC System 2
P1449 Evaporative Check Solenoid Circuit
P1450 Unable to Bleed Up Fuel Tank Vacuum
P1451 Evap Emission Control System Vent Control Circuit
P1452 Unable to Bleed Up Fuel Tank Vacuum
P1453 Fuel Tank Pressure Relief Valve Malfunction
P1454 Evaporative Emission System Vacuum Test
P1455 Evaporative Emission Control System Control Leak (gross leak/no flow)
P1456 Fuel Tank Temperature Sensor Circuit
P1457 Unable To Pull Fuel Tank Vacuum

So probably not a gas cap or filler hose issue

Find and check connection on Purge valve, then test hoses on purge valve
Pressure sensor could be at fault

When you get any code it is always good to check the other codes computer could have used for that system, helps eliminate other parts
 

98v70dad

Member
Joined
Oct 8, 2017
Messages
265
Reaction score
18
Points
18
Location
GA
Vehicle Year
1996
Make / Model
Ford
Engine Size
3.0L
Transmission
Automatic
2WD / 4WD
2WD
Some good info in this thread: http://www.therangerstation.com/forums/showthread.php?t=70038

The codes the computer does NOT choose to use are as important as the one it does use.

OBD2 codes here: http://www.therangerstation.com/tech_library/OBD-II_codes.shtml

Computer used P1443 and not :
P1440 Purge Valve Stuck Open
P1441 ELC System 1
P1442 Evaporative Emission System Control Leak Detected
(P1443 Evaporative Emission System Control Valve (low/no flow))
P1444 Evaporative Emission System Purge Flow Sensor Circuit Low Input
P1445 Purge Flow Sensor Circuit High Input
P1446 Evaporative Vacuum Solenoid Circuit
P1447 ELC System Closure Valve Flow
P1448 ELC System 2
P1449 Evaporative Check Solenoid Circuit
P1450 Unable to Bleed Up Fuel Tank Vacuum
P1451 Evap Emission Control System Vent Control Circuit
P1452 Unable to Bleed Up Fuel Tank Vacuum
P1453 Fuel Tank Pressure Relief Valve Malfunction
P1454 Evaporative Emission System Vacuum Test
P1455 Evaporative Emission Control System Control Leak (gross leak/no flow)
P1456 Fuel Tank Temperature Sensor Circuit
P1457 Unable To Pull Fuel Tank Vacuum

So probably not a gas cap or filler hose issue

Find and check connection on Purge valve, then test hoses on purge valve
Pressure sensor could be at fault

When you get any code it is always good to check the other codes computer could have used for that system, helps eliminate other parts
Good advice. I've never thought to do that. I don't get much from your prssure sensor comment though. Is the pressure sensor in the purge valve or is it a separate part?
 

RonD

Well-Known Member
Joined
Jun 2, 2012
Messages
18,517
Reaction score
2,993
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Not sure where it is in a 1996

EVAP Pressure sensor tells the computer if tank is holding pressure and if pressure is being released during Purge, by purge valve

It will be between purge valve and charcoal canister or on the gas tank
Never ran across one under the truck
 

98v70dad

Member
Joined
Oct 8, 2017
Messages
265
Reaction score
18
Points
18
Location
GA
Vehicle Year
1996
Make / Model
Ford
Engine Size
3.0L
Transmission
Automatic
2WD / 4WD
2WD
My dad gave me his 96 ranger XLT with 49,000 miles on it. He has had trouble code P1443 since 1998 but he lives in an area with no emission check so he let it ride. His fix was a piece of black electrical tape over the check engine light.

Anyhow, I'm in Atlanta and I can't register the truck in Georgia until I fix this. I have troubleshot evap systems before and know what a pain they can be to diagnose. My 20 year old volvo has had this same problem - major PITA.

Since the code showed up when the truck was only 2 years old I'm thinking that may be a hint. The code indicates its an evap system control valve but I know that it could also be a gas cap or a leak.

Can anyone tell me where that valve is located and what the most likely source of the problem could be considering that it showed up when the truck was nearly new.
I replaced the purge valve and that fixed it. Oddly the price for Chinese knock offs at auto parts stores was around $70. I found a new FoMOCo part in a sealed bag for $43 on Amazon with free shipping. It pays to look around!
 

RonD

Well-Known Member
Joined
Jun 2, 2012
Messages
18,517
Reaction score
2,993
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Good work :icon_thumby:

Thanks for the update and fix for the code
 

98v70dad

Member
Joined
Oct 8, 2017
Messages
265
Reaction score
18
Points
18
Location
GA
Vehicle Year
1996
Make / Model
Ford
Engine Size
3.0L
Transmission
Automatic
2WD / 4WD
2WD
Good work :icon_thumby:

Thanks for the update and fix for the code
Unfortunately I was too optimistic. I made it 40 miles to work code free but it returned on the way home tonight. I hate emission control system problems.

Its possible that the hose from the manifold to the thermister is pinched. The hose looks like its bent quite a bit and its separated from the tubing routing hardware meant to prevent that. I'll check it later in the week.

The first two times I got a similar code on my 20 year old volvo it was the purge valve. Getting rid of the code on the volvo the third time eventually involved replacing everything in the system. Hopefully that won't happen here.
 

OnAll4s

New Member
Joined
Nov 9, 2017
Messages
4
Reaction score
0
Points
0
Vehicle Year
1995
Make / Model
Ford Ranger
Transmission
Manual
Had the same problem replaced the valve and the solenoid that go after the charcoal canister. They are connected by a vacc hose and it has been good since
 

Super_Cracker

New Member
Joined
Feb 17, 2021
Messages
7
Reaction score
2
Points
3
Location
Tacoma wa
Vehicle Year
95
Make / Model
Ford ranger xlt
Transmission
Manual
My dad gave me his 96 ranger XLT with 49,000 miles on it. He has had trouble code P1443 since 1998 but he lives in an area with no emission check so he let it ride. His fix was a piece of black electrical tape over the check engine light.

Anyhow, I'm in Atlanta and I can't register the truck in Georgia until I fix this. I have troubleshot evap systems before and know what a pain they can be to diagnose. My 20 year old volvo has had this same problem - major PITA.

Since the code showed up when the truck was only 2 years old I'm thinking that may be a hint. The code indicates its an evap system control valve but I know that it could also be a gas cap or a leak.

Can anyone tell me where that valve is located and what the most likely source of the problem could be considering that it showed up when the truck was nearly new.
Yeah i have a 95 xlt ext.cab. with the 3.0 vulcan anyway i have had that same code for the 3rd time in 3 months. I changed the canister purge valve which is just after the canister would be drivers side just behind the headlight. Follow the largest tube coming out of the top.there will be a t connector on top and a round cylinder with an electric connector on the bottom that will continue to the thermistor which is connected to the intake by the throttle body. Opposite side of the throttle. I changed that canister purge valve solenoid,and the control valve, egr and tube,filler neck,and in process of changing all the hoses canister will be soon but can is not clogged but not getting power at all to the can.purge valve solenoid all fuses and relays good anyone know what to check next? I could choke a ford engineer right now. This is a frustrating code i have ever had to deal with.
 


Top