• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

91 ranger wont run right

Mr99Ranger

New Member
Joined
Jan 20, 2010
Messages
240
Reaction score
2
Points
0
Location
West Virginia
Vehicle Year
1991
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
ok so im considering buying another ranger after having sold my 99 over a year ago now. The problem is that the truck wont run right and me and the owner cant figure out why. the truck will start, but idles extremely rough and check engine light flicks on and off as the engine tries to die out. if you give it gas to and rev it up it will run smooth for a sec. with no cel but then the light will start to flicker on and off as the truck tries to die out again. truck also feels low on power. it is a 91 2.9 5 speed ranger. any ideas? i want the truck but i want to be able to drive it too haha.
 


adsm08

Senior Master Grease Monkey
Supporting Member
Article Contributor
Ford Technician
TRS 20th Anniversary
Joined
Sep 20, 2009
Messages
34,621
Reaction score
3,579
Points
113
Location
Dillsburg PA
Vehicle Year
1987
Make / Model
Ford
Engine Type
4.0 V6
Engine Size
4.0
Transmission
Manual
2WD / 4WD
4WD
Tire Size
31X10.50X15
Check for alternator output. Check both AC and DC. Sounds like its getting no power or dirty power.

Or the IAC is about shot.
 

Mr99Ranger

New Member
Joined
Jan 20, 2010
Messages
240
Reaction score
2
Points
0
Location
West Virginia
Vehicle Year
1991
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
alternator output is at 13 volts when the engine is running to spin it, could it be a vacuum leak?
 

adsm08

Senior Master Grease Monkey
Supporting Member
Article Contributor
Ford Technician
TRS 20th Anniversary
Joined
Sep 20, 2009
Messages
34,621
Reaction score
3,579
Points
113
Location
Dillsburg PA
Vehicle Year
1987
Make / Model
Ford
Engine Type
4.0 V6
Engine Size
4.0
Transmission
Manual
2WD / 4WD
4WD
Tire Size
31X10.50X15
it could be. spray some carb cleaner around the intake, see if that kills it.
 

Mr99Ranger

New Member
Joined
Jan 20, 2010
Messages
240
Reaction score
2
Points
0
Location
West Virginia
Vehicle Year
1991
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
ok i will try that i also forgot to mention the truck feels like it starts to lose power once warm as well like its slowly having more load applied to it or something
 

k3eaxk3eax

New Member
Joined
Oct 22, 2010
Messages
59
Reaction score
1
Points
0
Vehicle Year
1991
Make / Model
Ford
Transmission
Manual
What codes have you found in memory and what tests have you performed? Without information like that, it's difficult to give advice.

Al
 

snake

New Member
Joined
Aug 6, 2007
Messages
1,388
Reaction score
4
Points
0
Location
canyon lake tx
Vehicle Year
2011
Make / Model
Ford
Engine Size
3.5
Transmission
Automatic
If worse when hot the cat might be clogging too
 

Mr99Ranger

New Member
Joined
Jan 20, 2010
Messages
240
Reaction score
2
Points
0
Location
West Virginia
Vehicle Year
1991
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
i havent has a chance to try and pull codes yet but i talked to my boss today (former ford tech) and he says it sounds like a map sensor to him
 

Mr99Ranger

New Member
Joined
Jan 20, 2010
Messages
240
Reaction score
2
Points
0
Location
West Virginia
Vehicle Year
1991
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
it was a map sensor truck runs like new now!
 

Ak907Girl

New Member
TRS Banner 2012-2015
Joined
Dec 29, 2011
Messages
360
Reaction score
16
Points
0
Location
Anchorage, Alaska
Vehicle Year
2008
Make / Model
Ford
Engine Size
4.2L/ 11,370Miles
Transmission
Manual
EGR!!! mine is doing the same thing! 93 2.3L 5 speed manual. Lima had to talk me through reving my engine to see if the EGR will pop free and it did. KEEP REVING IT. or just do what I did and go 35mph down a busy highway in a 65mph zone till the valve pops free and you shoot off like a bottle rocket. lol Since I did that my EGR hasn't been giving me any problems and I even have slightly better acceleration...... not sure if its completely fixed but we'll see next time I'm at Lima's shop hopefully this week.
 

Mr99Ranger

New Member
Joined
Jan 20, 2010
Messages
240
Reaction score
2
Points
0
Location
West Virginia
Vehicle Year
1991
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
for my 2.9 a map sensor fixed the problem truck runs great now the 89 and up 2.9's dont have an egr valve, but glad the egr fix worked for your 2.3 though gotta love it when its something simple!
 
Last edited:

Mr99Ranger

New Member
Joined
Jan 20, 2010
Messages
240
Reaction score
2
Points
0
Location
West Virginia
Vehicle Year
1991
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
well truck ran great until i got on the interstate tonight then about half way home it started spitting and sputtering and cel flickering on and off again i thought the map sensor fixed it but guess not since it seems to be intermittent bad ecm maybe? let me know your ideas
 

Mr99Ranger

New Member
Joined
Jan 20, 2010
Messages
240
Reaction score
2
Points
0
Location
West Virginia
Vehicle Year
1991
Make / Model
Ford
Engine Size
2.9
Transmission
Manual
so i pulled the ecm today and it had surface rust on the outside and was damp and real rusty inside. My truck has a new windshield so id have to say the last one probably leaked and thats why it was replaced. So anyway i had an extra ecm out of an 88 f150 with a 300 i6 laying around to bolted the harness onto it and the truck fired up and ran ok, much better than it did, and the fuel pump shut off after 2 secs instead of staying running like it was. so i've ordered a reman ecm and im considering driving it with the 300 ecm till it gets here friday, will that hurt anything?
 

Sponsored Ad


Sponsored Ad

Top