• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

88 bronco 2 help...no spark

detty_motorsports

New Member
Joined
Sep 21, 2009
Messages
285
Reaction score
2
Points
0
Age
37
Location
chillicothe,ohio
Vehicle Year
1988/1992
Make / Model
ford/ford
Engine Size
2.9
Transmission
Automatic
i have recently bought a 88 bronco 2 it had set for sevral years. the guy i bought it from said the reason that he quit driving it was because that it would die and not start until it cooled down.....but now it will not startat all.... what i have found so far is that i have no spark... i do have power to the coil. ...
 
Last edited:


detty_motorsports

New Member
Joined
Sep 21, 2009
Messages
285
Reaction score
2
Points
0
Age
37
Location
chillicothe,ohio
Vehicle Year
1988/1992
Make / Model
ford/ford
Engine Size
2.9
Transmission
Automatic
:icon_welder: well i couldnt sleep last night so i went to the garage and found out some more.....i went through the glove box and found a bunch of recipts and work logs according to what i found the motor and tranny are fairly new... about 50000 miles and it is a jasper motor.....

also i have power to the coil like i said before but there is no spark going to the distribtor. what could this be??
 

BlackBII

Ranger Custom
Article Contributor
OTOTM Winner
TRS Banner 2010-2011
Joined
Aug 14, 2007
Messages
7,874
Reaction score
839
Points
113
Location
UT
Vehicle Year
1989
Make / Model
Ford
Engine Type
4.0 V6
Transmission
Manual
2WD / 4WD
4WD
Total Lift
5
Tire Size
33
Are you getting no spark only when it's Hot? Or no spark alltogether?

I would suspect the TFI module.
 

master hec0

New Member
Joined
Aug 29, 2009
Messages
800
Reaction score
5
Points
0
Location
okotoks alberta canada
Vehicle Year
2011
Make / Model
Ford
Engine Size
4.0L V6
Transmission
Manual
i had this issue replaced the distributor cap and rotor new coil then replaced the tfi it fixed my initial no spark issue.
 

detty_motorsports

New Member
Joined
Sep 21, 2009
Messages
285
Reaction score
2
Points
0
Age
37
Location
chillicothe,ohio
Vehicle Year
1988/1992
Make / Model
ford/ford
Engine Size
2.9
Transmission
Automatic
Are you getting no spark only when it's Hot? Or no spark alltogether?

I would suspect the TFI module.
no spark at all

i bought an ignition module and the coil pick up.... oh and the cap and rotor i got the upper intake off tonight and the distributor out but one of the cap bolts broke off..... but i drilled and tapped it but i ran out of time so ill put it togeather tomorow and let u know what happens.......
 

detty_motorsports

New Member
Joined
Sep 21, 2009
Messages
285
Reaction score
2
Points
0
Age
37
Location
chillicothe,ohio
Vehicle Year
1988/1992
Make / Model
ford/ford
Engine Size
2.9
Transmission
Automatic
well i changed everything today and i still wouldnt start..... untill i swapped the coli out with my buddys then i noticed that one of the wires was coroded so i cut it back and put a new end on it then it fired..........:icon_hornsup:
 

detty_motorsports

New Member
Joined
Sep 21, 2009
Messages
285
Reaction score
2
Points
0
Age
37
Location
chillicothe,ohio
Vehicle Year
1988/1992
Make / Model
ford/ford
Engine Size
2.9
Transmission
Automatic
problem solved...... it was a bad(corroed) wire at the coil.............:headbang::headbang::headbang:
 

BlackBII

Ranger Custom
Article Contributor
OTOTM Winner
TRS Banner 2010-2011
Joined
Aug 14, 2007
Messages
7,874
Reaction score
839
Points
113
Location
UT
Vehicle Year
1989
Make / Model
Ford
Engine Type
4.0 V6
Transmission
Manual
2WD / 4WD
4WD
Total Lift
5
Tire Size
33
Glad to hear you got it fixed. :icon_thumby:
 

detty_motorsports

New Member
Joined
Sep 21, 2009
Messages
285
Reaction score
2
Points
0
Age
37
Location
chillicothe,ohio
Vehicle Year
1988/1992
Make / Model
ford/ford
Engine Size
2.9
Transmission
Automatic
thanks....... but got new problems now..........no fuel.........:icon_confused::icon_confused::icon_confused:
 

master hec0

New Member
Joined
Aug 29, 2009
Messages
800
Reaction score
5
Points
0
Location
okotoks alberta canada
Vehicle Year
2011
Make / Model
Ford
Engine Size
4.0L V6
Transmission
Manual
no fuel at all or just not enough to keep it running? are you positive it is no fuel?
if not disconnect the ignition coil and crank the engine then remove the spark plugs and see if they are wet with fuel.
 

Mountanman83

New Member
Joined
Sep 26, 2009
Messages
9
Reaction score
0
Points
0
Location
west virginia
Vehicle Year
1986
Make / Model
ford
Engine Size
302 bored and cam
Transmission
Manual
Check the relay on the passenger fender is it kicking the pump on. If so you should here it when you turn the key
 

master hec0

New Member
Joined
Aug 29, 2009
Messages
800
Reaction score
5
Points
0
Location
okotoks alberta canada
Vehicle Year
2011
Make / Model
Ford
Engine Size
4.0L V6
Transmission
Manual
Check the relay on the passenger fender is it kicking the pump on. If so you should here it when you turn the key
just to reiterate a bit don't start the vehicle just put the key to the on position and the noise will be a whirling noise that's the best i can describe it as.
also go post this on www.broncoII.org some members check here but i think you will get more help if you also posted it there
 

detty_motorsports

New Member
Joined
Sep 21, 2009
Messages
285
Reaction score
2
Points
0
Age
37
Location
chillicothe,ohio
Vehicle Year
1988/1992
Make / Model
ford/ford
Engine Size
2.9
Transmission
Automatic
ok bad news..... dropped the tank and its shot.... ordered a new tank and both fuel pumps...... the tank was full of rust.... it was bad so bad that the fuel sock was rotted off..... i checked the voltage at the in tank pump and its good so i think ill be fine once i replace the tank and pumps and fliter......
 

master hec0

New Member
Joined
Aug 29, 2009
Messages
800
Reaction score
5
Points
0
Location
okotoks alberta canada
Vehicle Year
2011
Make / Model
Ford
Engine Size
4.0L V6
Transmission
Manual
hey what were your symptoms? did it just not start or run for a while and then start stalling and running rough?
 

detty_motorsports

New Member
Joined
Sep 21, 2009
Messages
285
Reaction score
2
Points
0
Age
37
Location
chillicothe,ohio
Vehicle Year
1988/1992
Make / Model
ford/ford
Engine Size
2.9
Transmission
Automatic
replaced tank pumps and filter and every things good now
 

Sponsored Ad


Sponsored Ad

Top