• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' the posts that you read.

84 bronco II 2.8 rattle noise lower engine


mightysonofa

New member
Joined
May 1, 2011
Messages
26
Reaction score
2
Points
0
Location
mars
Vehicle Year
1984
Make / Model
ford
Engine Size
2.8
Transmission
Manual
I have a 84 b2 2.8L with 119,000 0n it . out of the blue it started to make a strange rattle noise heard either at cold start and then after warm up at idle , it sounds like very loose lifters it does not hesitate or lack power nor does it have a miss ,I have always changed the oil and other than the rattle noise it runs and drives fine .If I go to start it and it doesn't start right away as the engine is still spinning a bit you can hear it the best . it almost sound like something in the bottom of the engine not a rod but a loud rattle. Like something rolling around in there I've checked the exhaust it is all brand new from the y pipe back even the cat is new .if it is making the noise as soon as I give it a bit of gas it goes away .I took it to a shop they said it has low oil pressure . If so do I need a new engine or should I pull the engine and replace the pump then adjust he valves and see what's up after that .I haven't had much experience with these old engines . one guy told me it sounds like the timing gear has broken off but I don't hear the noise under the hood just under the truck in the lower engine . Any Ideas?
 


Rock Auto 5% Discount Code: 80CBDBD15DC160 Expires: January 4th, 2021

drsvox

Member
U.S. Military - Veteran
Joined
Sep 26, 2013
Messages
240
Reaction score
1
Points
18
Location
Prattville, AL
Vehicle Year
1983
Make / Model
Ford
Engine Size
V6 2.8L
Transmission
Automatic
I seriously doubt it's a broken timing gear. You wouldn't likely be running if it were.

If your oil pressure is low, it could be the pump. But I suppose it could also just be a bad pressure sender.

Bad oil pump wouldn't necessarily mean a new engine, but that would depend on how long you've been running the engine with a bad pump (assuming that's the problem).

You don't need to pull the engine to get to the pump. Unbolt the transmission from the cross member; remove the distributor (and carb if it makes it easier); remove the engine mount nuts. Then use a jack to lift the engine enough to place wooden blocks under the mounts...cut four lengths of 2x4s, enough to place two on each side under the mounts. Then slowly lower the engine onto the blocks. This should give you enough clearance to unbolt, lower, and remove the oil pan (after you drain the oil of course). This should also give you enough clearance to remove the oil pump (replace it with new; do not buy a rebuild kit). Check and replace (if necessary) the oil pump shaft. Gaskets will come with the new oil pump.

Again, this is assuming the oil pump is bad, but didn't cause any damage to the bearings...which you won't know unless you pull the engine and tear it down, or unless you find bearing fragments in the oil pan when you check it.

EDIT: You shouldn't have to mess with adjusting the valve lashings. Once they're set, they're pretty much set, and adjusting them can be a tricky PITA.
 
Last edited:


Top