84 Bronco 2 Conversion - 2.8L to 4.0L : No start condition


RagingBronco

New member
Joined
May 31, 2019
Messages
8
Reaction score
1
Points
3
Location
Colorado
Vehicle Year
1984
Make / Model
Ford Bronco 2
Transmission
Manual
Long time lurker, first time poster here! Recently I took over someone else’s project of swapping the 2.8L carbureted engine out of an 84 Bronco II, for a 4.0 fuel injected engine originally from a 91 Explorer. I was told that the donor vehicle was actually a 91 Ranger that already had the 4.0L swap complete, so the wiring harness had already been modified for the 4.0L conversion.

Let’s fast forward a bit. I’ve been troubleshooting a crank but no start problem. I ended up finding out that the spark plugs were not getting spark, and that the three switching signal circuits of the coil pack connector were not receiving any signal while cranking the engine. I do however have 12V at the coil pack connector.

I ended up testing the EEC Relay and the EEC itself, everything tested fine. The EEC and Fuel Pump Relays click when the key is turned to the run position. I also tested the crank sensor by cranking the engine and measuring AC voltage, which gave me around 1.5V. I then started testing grounds. I tested the ground wire at the EDIS 6 module, pin 10 for PWR GND. If the key is in the off position I receive 12V ground. If the key is turned to the run position I lose 12V and it drops down to 10.3V. Weird.

I started tracing this ground wire and noticed that it led to a 2 wire connector that had been snipped underneath the battery. I looked in my explorer wiring diagram (picture of connector and diagram below) and saw that these two wires should be grounded to the battery. Once I grounded the wires with the key still in the run position, all of my relays clicked just like they would if I had removed and reconnected the s terminal starter solenoid wire. Odd. I tested pin 10 (PWR GND) once again with the key in the run position and now received 12V.

Without an assistant, I jumped the s terminal and the positive starter solenoid terminal and I started receiving spark! I then sprayed some starting fluid into the intake, jumped the solenoid, and the engine fired for about a second! Finally, problem solved! Or so I thought. I got back into the truck, tried to crank the engine, and nothing. With those two ground wires connected to the battery, I lose 12V to the s terminal cable and the bronco won’t crank with the turn of the key. I remove the grounds from the battery and the bronco will crank, but I won’t receive any spark.

What the heck is going on here? It seems like there could either be a short somewhere in the wiring harness, or I’ve hooked something up incorrectly and it’s causing problems. Maybe the starter solenoid isn’t wired properly? I’m open to suggestions and can’t wait to get this thing running!

For some reason I can't attach pictures? Only from a hyperlink?
 


Rock Auto 5% Discount Code: 173A8B749AB83C Expires: January 1, 2020


Top