• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

4x4 light not working


McFuzzie

Member
Joined
Feb 25, 2010
Messages
34
Reaction score
0
Points
6
Location
Vancouver, WA
Vehicle Year
1991
Make / Model
Ford
Engine Size
4.0 L V6
Transmission
Manual
Hello,

When I shift into 4x4 High the little "4x4" light on the dash board will not come on. This happens when I shift into 4x4 Low also, but the "Low Range" light comes on. I've checked the fuses and none of them are bad. I'm pretty sure my 4 wheel drive isn't broken because when I shift into 4x4 H it drives different. So what could be the problem? I have manual locking hubs and I don't have the push button system. I also have a 4.0L engine.

Thanks,

Kyle
 


Rock Auto 5% Discount Code: F9A1A579ACFAD1: October 1st, 2021

martin

New Member
Joined
Aug 6, 2007
Messages
3,219
Reaction score
22
Points
0
Age
74
Location
St Bruno, Quebec
Vehicle Year
1984
1991
Make / Model
ford
Transmission
Manual
perhaps the bulb is burned?
 

sfwjesse

New Member
Joined
May 9, 2008
Messages
314
Reaction score
0
Points
0
Age
38
Location
New Hampshire
Vehicle Year
1993
Make / Model
Ford
Engine Size
4.0
Transmission
Manual
Thats the first thing i would check....my old B2 used alot of those little tiny bulbs in the dash and 3 of them were dead when i bought it.

The next thing to check would be the switch that senses you are in 4x4....im guessing there has to be one somewhere on the transfer case or shifter.
 

McFuzzie

Member
Joined
Feb 25, 2010
Messages
34
Reaction score
0
Points
6
Location
Vancouver, WA
Vehicle Year
1991
Make / Model
Ford
Engine Size
4.0 L V6
Transmission
Manual
Thats the first thing i would check....my old B2 used alot of those little tiny bulbs in the dash and 3 of them were dead when i bought it.

The next thing to check would be the switch that senses you are in 4x4....im guessing there has to be one somewhere on the transfer case or shifter.
Did you end up changing them? I popped off the trim around the dash board to check the bulb and I can't reach it. It looks like I have to take out the whole instrument cluster just to get to the bulb. Do I have to do that or am I over looking for something?
 

snoman6115

New Member
Joined
May 24, 2009
Messages
282
Reaction score
1
Points
0
Location
Weston, WI
Vehicle Year
1998
Make / Model
Ford
Engine Size
v6 4.0
Transmission
Automatic
no u do. on my 98 its pretty simple idk bout older models tho
 


Top