• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

4.0l ohv not starting after rebuilt long block

93rangerxlt-ca

New Member
Joined
Apr 19, 2016
Messages
13
Reaction score
0
Points
0
Vehicle Year
1993
Make / Model
Ford
Transmission
Automatic
I put a long block in my 93 had it running til cam position sensor broke . I put new one in with motor on Tdc and now wont.run. I have spark and fuel. Now im stuck please help
 


Rock Auto 5% Discount Code: BD8D9A3814E19D Expires July 5th, 2022

RonD

Well-Known Member
Joined
Jun 2, 2012
Messages
21,722
Reaction score
5,129
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Do 50/50 test
Spray gasoline or quick start into the intake
Then try to start
If it starts and dies then you do not have fuel

If it does not start then you do not have spark

50/50

Having fuel pressure does not mean engine is getting fuel

Testing spark does not mean spark is at the right time

I take it you are in Calif. or this was a Calif. Ranger
1993 4.0l didn't have Cam sensor except in Calif.

And what do you mean by "broken" cam sensor, did the Syncro unit break?
Gear issue?
That could mean cam or timing chain was the real issue not the cam sensor
Which would call for compression test, just to take that off the table, or not waste time on other things if it is a timing chain issue

There are two TDCs on 4-stroke engines, so you have a 50/50 chance of getting it right if you just turned crank to TDC and installed the synchro unit.
Synchro needs to be timed to #1 at TDC compression stroke, other TDC is #1 exhaust stroke
You can remove #1 spark plug and turn crank manually to tell which is which.
 
Last edited:

93rangerxlt-ca

New Member
Joined
Apr 19, 2016
Messages
13
Reaction score
0
Points
0
Vehicle Year
1993
Make / Model
Ford
Transmission
Automatic
The cam sensor plug broke and the plastic locked it up , btw powertorque is where I bought the long block from. Ive took it half apart a few times and everytime i put it back together im getting same results following a haynes book
 

93rangerxlt-ca

New Member
Joined
Apr 19, 2016
Messages
13
Reaction score
0
Points
0
Vehicle Year
1993
Make / Model
Ford
Transmission
Automatic
Is there anyway of testing coil pack or could the timing chain jump a tooth beings that syncro locked up im not a mechanic just an idiot playin mechanic and just a bit tired of shoot from the hip haha
 

Sponsored Ad


Sponsored Ad

Top