• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

4.0 OHV how to tell which wire is for which o2 sensor

thcscubajohn

Active Member
Joined
Nov 23, 2014
Messages
147
Reaction score
31
Points
28
Location
Antarctica
Vehicle Year
1994
Make / Model
FORD
Engine Type
4.0 V6
Engine Size
247ci
Transmission
Manual
2WD / 4WD
4WD
Total Lift
4"
Tire Size
31x10.50r15
My credo
Smog is for pussies.
I recently installed my engine and I can't figure out which plug is for which o2. They bothe dangle down from the middle and could go to either side. One has a pink wire protector and the other black.
 


Dirtman

Former Middleweight Moss Fighting Champion
Supporting Member
Joined
May 28, 2018
Messages
19,339
Reaction score
13,347
Points
113
Location
41N 75W
Vehicle Year
2009
Engine Type
2.3 (4 Cylinder)
Transmission
Automatic
2WD / 4WD
2WD
Total Lift
It's up there.
Total Drop
It's down there.
Tire Size
Round.
My credo
I poop in the furnace.
Plug one in and leave the other off. Whichever bank immediately throws a code is the bank where the unplugged wire goes. :dunno:
 

broncc

Well-Known Member
Ham Radio Operator
Joined
Nov 30, 2020
Messages
211
Reaction score
262
Points
63
Location
MA, USA
Vehicle Year
1989
Make / Model
Ford Bronco II
Engine Type
4.0 V6
Transmission
Manual
2WD / 4WD
4WD
Total Lift
6
Tire Size
31
My credo
Giving my truck more money than it deserves.
bank 1 should use a gray wire and bank 2 should use a red wire
 
Last edited:

thcscubajohn

Active Member
Joined
Nov 23, 2014
Messages
147
Reaction score
31
Points
28
Location
Antarctica
Vehicle Year
1994
Make / Model
FORD
Engine Type
4.0 V6
Engine Size
247ci
Transmission
Manual
2WD / 4WD
4WD
Total Lift
4"
Tire Size
31x10.50r15
My credo
Smog is for pussies.
Plug one in and leave the other off. Whichever bank immediately throws a code is the bank where the unplugged wire goes. :dunno:
I would, but its pre-obd and I somehow lost my diagnostic port when I swapped cabs
 

RonD

Well-Known Member
Joined
Jun 2, 2012
Messages
22,654
Reaction score
5,773
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
A shop reversed my O2 sensors, ran fine cold then bad after warm up
Ran fine at WOT(wide open throttle)
O2s are not used when engine is cold or at WOT

Set Lean on bank 1 and Rich on Bank 2 codes, lol

So won't hurt anything to get it wrong, just run poorly after warm up, if so swap them around

3 of the 4 wires will be the same on the truck side of O2 harnesses
In 1994 4.0l two will be different
Red/black stripe wire is drivers side(bank 2)
Grey/light blue strip wire is passengers side(bank 1)
 
Last edited:

thcscubajohn

Active Member
Joined
Nov 23, 2014
Messages
147
Reaction score
31
Points
28
Location
Antarctica
Vehicle Year
1994
Make / Model
FORD
Engine Type
4.0 V6
Engine Size
247ci
Transmission
Manual
2WD / 4WD
4WD
Total Lift
4"
Tire Size
31x10.50r15
My credo
Smog is for pussies.
Ok, I switched the wires and drove it. It seemed ro run fine warm before. I did get an intermittent check engine light that would clear itself if I kept driving or restarted the engine. There was no change to drivability with the code. Now there is no code, but it won't idle down. The rpm won't drop below 1.2-1.4k.
 

thcscubajohn

Active Member
Joined
Nov 23, 2014
Messages
147
Reaction score
31
Points
28
Location
Antarctica
Vehicle Year
1994
Make / Model
FORD
Engine Type
4.0 V6
Engine Size
247ci
Transmission
Manual
2WD / 4WD
4WD
Total Lift
4"
Tire Size
31x10.50r15
My credo
Smog is for pussies.
Ok so its a pain in the nuggets to fiddle with these wires. I managed to take pictures of the wires and they are plugged in correctly now.
Driver's side bank 2 has the red/black;
20210709_161421.jpg

And the passenger side bank 1 has the grey/blue;20210709_161447.jpg

I'm glad I got the sensor with the longest wire for both sides, my hands could be alot more crispy.
Denso 234-4210
 
Last edited:

thcscubajohn

Active Member
Joined
Nov 23, 2014
Messages
147
Reaction score
31
Points
28
Location
Antarctica
Vehicle Year
1994
Make / Model
FORD
Engine Type
4.0 V6
Engine Size
247ci
Transmission
Manual
2WD / 4WD
4WD
Total Lift
4"
Tire Size
31x10.50r15
My credo
Smog is for pussies.
A shop reversed my O2 sensors, ran fine cold then bad after warm up
Ran fine at WOT(wide open throttle)
O2s are not used when engine is cold or at WOT

Set Lean on bank 1 and Rich on Bank 2 codes, lol

So won't hurt anything to get it wrong, just run poorly after warm up, if so swap them around

3 of the 4 wires will be the same on the truck side of O2 harnesses
In 1994 4.0l two will be different
Red/black stripe wire is drivers side(bank 2)
Grey/light blue strip wire is passengers side(bank 1)
Thank you Ron. You always have the right information.
 

Sponsored Ad


Sponsored Ad

Top