• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

2010 motor cutting out


Lauchlin

New Member
Ham Radio Operator
Joined
Oct 9, 2022
Messages
9
Reaction score
1
Points
3
Location
Duncan BC
Vehicle Year
2010
Make / Model
Mazda B4000
Transmission
Automatic
I have a 2010 b 4000 with 65000 km on it starts and runs fine after a few min around 5 to 10 the motor stalls at any speed but starts right back up then any were from 3 to 10 min cuts out again ? Dose not any codes and new parts just replace are fuel pump, Cam sensor ,Coil pack .....was going to try a new Mazda ECM ECU PCM but there is some security set up in i could not get passed ....Any ideas would be great ...
 


franklin2

Well-Known Member
Joined
Dec 24, 2019
Messages
3,278
Reaction score
1,629
Points
113
Location
Virginia
Vehicle Year
1984
Make / Model
Bronco II
Transmission
Manual
Cleaned the throttle body and the idle air control valve?
 

Lauchlin

New Member
Ham Radio Operator
Joined
Oct 9, 2022
Messages
9
Reaction score
1
Points
3
Location
Duncan BC
Vehicle Year
2010
Make / Model
Mazda B4000
Transmission
Automatic
New idle air control valve
 

franklin2

Well-Known Member
Joined
Dec 24, 2019
Messages
3,278
Reaction score
1,629
Points
113
Location
Virginia
Vehicle Year
1984
Make / Model
Bronco II
Transmission
Manual
Cleaned the throttle blade?
 

Lauchlin

New Member
Ham Radio Operator
Joined
Oct 9, 2022
Messages
9
Reaction score
1
Points
3
Location
Duncan BC
Vehicle Year
2010
Make / Model
Mazda B4000
Transmission
Automatic
No i have not done that it seem like it electrical and i have change all the relay ...I will clean the throttle in the morning you never know and thank you
 
Last edited:

franklin2

Well-Known Member
Joined
Dec 24, 2019
Messages
3,278
Reaction score
1,629
Points
113
Location
Virginia
Vehicle Year
1984
Make / Model
Bronco II
Transmission
Manual
On the idle air, a portion comes from the crack around the throttle blade, the rest is made up by the computer and the idle air valve you replaced. The throttle likes to get dirty and plugged with this sticky brown carbon build-up. That can plug off some of the air coming through the throttle, and it gives a chance for it to stall, the computer is good at trimming the air flow, not supplying all of it the engine requires.

If you find it was dirty, you may need to give it a chance and a couple of restarts for the computer to adjust itself and relearn the idle parameters.
 

Lauchlin

New Member
Ham Radio Operator
Joined
Oct 9, 2022
Messages
9
Reaction score
1
Points
3
Location
Duncan BC
Vehicle Year
2010
Make / Model
Mazda B4000
Transmission
Automatic
I cleaned every thing around the throttle shaft it was very clean to start with but it made no difference's ....I forgot to mention fuse 44 popped just before this started i replaced it and cutting out started ......
 

Sponsored Ad


Sponsored Ad

Staff online

Today's birthdays

Member & Vendor Upgrades

For a small yearly donation, you can support this forum and receive a 'Supporting Member' banner, or become a 'Supporting Vendor' and promote your products here. Click the banner to find out how.

Latest posts

Truck of The Month


Yotaismygame
February Truck of The Month

Recently Featured

Want to see your truck here? Share your photos and details in the forum.

Follow TRS On Instagram

TRS Events

Check Out The TRS Store


Sponsored Ad


Sponsored Ad

Sponsored Ad


Amazon Deals

Top