• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

2001 4x4 Woes

Joined
Mar 15, 2022
Messages
1
Reaction score
0
Points
1
Location
Inyokern, CA
Vehicle Year
2001
Make / Model
Ford Ranger 4x4
Transmission
Automatic
Friends,

I'm having trouble with the 4x4 working reliably. I've read some of the troubleshooting about this but I haven't seen this particular scenario discussed. So, when I start the vehicle the 4WD light on the dash doesn't light. The 4x4 Switch does not light with engine running and does not engage the 4x4. I read somewhere that you can get the relay to reset by disconnecting the battery (which apparently allows the ECM to see the switch). When I do this for a couple of hours and reconnect, the 4wd light comes on and the switch works. I can hear the relay working, and the switch lights to appropriate drive selection. But it only works once, and then its stuck in whatever I selected. Then I have to re-do the battery disconnect process to reset it. The battery reset sometimes takes a couple tries and sometimes overnight. This is a problem because my girl drives it when there's snow, and I can't expect her to get under the hood to play with it herself. I've had occasion where I pull the fuse and get the same effect, but it's not reliable enough. The fuse is never blown. Thoughts on how to resolve?

ESR
 


superj

Well-Known Member
U.S. Military - Veteran
Joined
Oct 1, 2021
Messages
1,911
Reaction score
1,315
Points
113
Location
corpus christi, texas
Vehicle Year
2004
Make / Model
ranger edge
Engine Type
3.0 V6
Engine Size
3 liters of tire smoking power
Transmission
Manual
2WD / 4WD
2WD
Total Lift
none
Total Drop
none
Tire Size
235s
My credo
Grew up in the 70s, 80s, and 90s
welcome to the site!!

i cannot help because my truck is not 4x4 so i have no experience to aid. hopefully one of the guys who has a 4x4 can come help though
 

Sponsored Ad


Sponsored Ad

Top