• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

2.5L ('98-'01) 2000 Ranger won't start and run without foot on the gas


BL84

New Member
Joined
Oct 11, 2020
Messages
3
Reaction score
0
Points
1
Location
Chester1bl!
Vehicle Year
2000
Make / Model
Ford Ranger
Transmission
Manual
Hi, I have a 2000 Ranger 2.5L manual tranny, I had replaced the fuel pump and sending unit to get it to start up again after sitting for a couple months. It then would start but anytime you revved it up it would die when you released the throttle. I have since replaced the MAF sensor and housing, the IAC, the TPS (and cleaned the throttle body housing), the intake manifold gasket, the EGR valve and tube, the O2 sensors and the vapor cannister purge valve. Now it barely starts and only stays running when the gas pedal is pressed but it doesn't sound like it wants to be running when you do that, it dies when you release the gas and it even if you keep pressing the gas pedal it seems to peter out and die. I replaced some of the vacuum hose that was old as well but went through and checked all the connections, and everything seems to be in order, it doesn't have any codes stored or pending, but I can't get any live data because it won't run long enough, I am kind of stumped at the moment.
 


Rock Auto 5% Discount Code: 7FA902352B4C01: April 5th, 2021

RonD

Well-Known Member
Joined
Jun 2, 2012
Messages
17,718
Reaction score
2,653
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Welcome to TRS :)

I assume you also changed fuel filter when you did the fuel pump?

Check Vacuum when cranking engine over, should be about 2"-3"
If not then exhaust may be blocked or timing belt has skipped a tooth(low compression)

After only a couple of months the gas in the tank should still be OK
 

BL84

New Member
Joined
Oct 11, 2020
Messages
3
Reaction score
0
Points
1
Location
Chester1bl!
Vehicle Year
2000
Make / Model
Ford Ranger
Transmission
Manual
Welcome to TRS :)

I assume you also changed fuel filter when you did the fuel pump?

Check Vacuum when cranking engine over, should be about 2"-3"
If not then exhaust may be blocked or timing belt has skipped a tooth(low compression)

After only a couple of months the gas in the tank should still be OK

Hi, thank you :) I did not change the fuel filter as it had not been that long and it had not had a problem starting or idling until I changed the intake manifold gasket and O2 sensors. The battery did not have enough charge to turn it over though until I put it on the jump starter if that gives you any ideas. I thought I would get a fuel filter tomorrow just to be thorough though, I need to have someone start it so I can watch the engine to see if anything is amiss, it definitely sounds like it is unhappy.
 

RonD

Well-Known Member
Joined
Jun 2, 2012
Messages
17,718
Reaction score
2,653
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
O2 sensors only work when they are heated above 650degF so are never used when starting, and if engine was cold then they are not used for the first few minutes of running

A vacuum leak in intake manifold gasket could cause slow start but would have to be a bigger leak

Partially clogged fuel filter wouldn't cause slow start but would cause limited RPMs and low power

If you can get your hands on a vacuum gauge($20) then I would see what that tells you, one of the better diagnostic tools for gasoline engines
 

Locotomb

Active Member
Joined
Jul 26, 2017
Messages
114
Reaction score
62
Points
28
Location
Puyallup, WA
Vehicle Year
1988, 1986
Make / Model
Ford Ranger
Engine Type
2.9 V6
Engine Size
2.3l
Transmission
Manual
2WD / 4WD
2WD
Total Lift
6inch custom fab lift/86
Total Drop
Bagged 3 inch custom drop beams 88/89 Custom triangulated and step notched rear
Tire Size
35/12.5/r18
My credo
Everything looks better lower
I’m with you Ron, Gasket leak. Or, maybe even a stuck closed IAC valve.
 

BL84

New Member
Joined
Oct 11, 2020
Messages
3
Reaction score
0
Points
1
Location
Chester1bl!
Vehicle Year
2000
Make / Model
Ford Ranger
Transmission
Manual
It actually is the cat that is clogged, I removed the upstream O2 sensor and it started up and ran no problem, I am sure that cat was on it's last leg anyhow. At least it makes sense that was driving me crazy...
 

RonD

Well-Known Member
Joined
Jun 2, 2012
Messages
17,718
Reaction score
2,653
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Good work

Thanks for the update and the FIX
 


Top