1999 ranger v8 swap from a 1999 expo


Andrew.V

Member
Joined
Sep 5, 2017
Messages
43
Reaction score
1
Points
8
Location
Manitoba Canada
Vehicle Year
2008 fx4
1988
Make / Model
Ford
Engine Size
4.0 5.0 2.5
Transmission
Automatic
So I did this swap over my Christmas brake got it running and driving (yay) I ended up swapping the dash and complete engine bay harness so I could keep the cruise and auto climate control. Any ways the one big ish problem I have is my speedo does not work so do I have to swap the abs pump or can I rig some thing up and keep my stock 99 2.5 abs module in place. I don't think the bcm swap is an option because my truck is so base model didn't have cruise or power windows. truck has a 4r70w if that will make a difference. Thanks for any help
 


Rock Auto 5% Discount Code: CFB3B5F7F32B37 Expires: March 30, 2020

fastpakr

Forum Staff Member
Forum Moderator
U.S. Military - Veteran
V8 Engine Swap
TRS 20th Anniversary
Joined
Aug 6, 2007
Messages
5,066
Reaction score
438
Points
83
Location
Roanoke, VA
Vehicle Year
1999
Make / Model
Ford
Engine Type
V8
Engine Size
5.0
Transmission
Automatic
2WD / 4WD
4WD
Tire Size
285/75-16
I'm honestly not sure why you'd have lost speed signal. Doesn't it go from rear axle to ecm to trans/speedo/abs? Mine worked fine after the swap.
 

Andrew.V

Member
Joined
Sep 5, 2017
Messages
43
Reaction score
1
Points
8
Location
Manitoba Canada
Vehicle Year
2008 fx4
1988
Make / Model
Ford
Engine Size
4.0 5.0 2.5
Transmission
Automatic
that's what I thought the only thing I can think Is that something is pinned different in the chassis to dash plug from expo to ranger kind of like how I had to re wire my tail lights ( brake lights where in front signals lol ) do you know what the colors are I could always splice stuff if I have to.
 

fastpakr

Forum Staff Member
Forum Moderator
U.S. Military - Veteran
V8 Engine Swap
TRS 20th Anniversary
Joined
Aug 6, 2007
Messages
5,066
Reaction score
438
Points
83
Location
Roanoke, VA
Vehicle Year
1999
Make / Model
Ford
Engine Type
V8
Engine Size
5.0
Transmission
Automatic
2WD / 4WD
4WD
Tire Size
285/75-16
I kept the original dash intact and just used the explorer engine and transmission wiring. As I recall, I had to flip one connector in the engine compartment and move one behind the ignition sister to make the tach read correctly. That left all functions intact including my stock Ranger cruise control.
 

Andrew.V

Member
Joined
Sep 5, 2017
Messages
43
Reaction score
1
Points
8
Location
Manitoba Canada
Vehicle Year
2008 fx4
1988
Make / Model
Ford
Engine Size
4.0 5.0 2.5
Transmission
Automatic
Thats what I was going to do originally but I thought having cruise would be nice and auto climate control so I swapped the steering wheel and dash to save wiring in those features . kind of dumb in hind sight. problem with a base model all it had was a/c. I dont care about the abs light just want spedo abs light was on in the expo but the spedo and cruise still worked. thought's on the chassis to dash plug having something that needs to be rewired?
 

win

Member
U.S. Military - Veteran
V8 Engine Swap
Joined
Jan 13, 2014
Messages
323
Reaction score
7
Points
18
Vehicle Year
2002
Make / Model
Ford
Engine Size
5.0
Transmission
Automatic
How much of the dash did you swap to install the climate and cruise control?

On the 4 cyl Rangers, the GEM provides the speed signal and you might have inadvertently lost that function with the wiring/feature upgrades.

Yes, wiring in the ABS module(can use Ranger valve body) and G-Force sensor from the Expo should correct the speedometer signal problem.

Not sure the auto climate will work if you swap/wire back in the GEM.

Or, Dakota Digital makes a module to take ABS signal and generate the correct speed signal.
 

sheep herder

Well-known member
U.S. Military - Veteran
Joined
Nov 7, 2019
Messages
361
Reaction score
259
Points
63
Location
sheep pen
Vehicle Year
2011
Make / Model
Ford Ranger
Engine Type
4.0 V6
Transmission
Automatic
2WD / 4WD
2WD
Anyone know how to figure out why my clutch push rod wont go into the master cylinder?
Maybe start your own thread in the proper section. Better chance of getting an answer. Or just use the search function.
 

Andrew.V

Member
Joined
Sep 5, 2017
Messages
43
Reaction score
1
Points
8
Location
Manitoba Canada
Vehicle Year
2008 fx4
1988
Make / Model
Ford
Engine Size
4.0 5.0 2.5
Transmission
Automatic
The easiest way to put it is I unhooked the one dash and put it into the other truck and plugged it in. I also took the complete engine bay harness out of the expo so i wouldn't have to wire the cruise in. so if I where to just plug the abs pump into the harness not plumbed or anything and wired in the G-force sensor should that fix it. also where is the G-fore module located? another thought is could I just loop some of the pump wires?
 

win

Member
U.S. Military - Veteran
V8 Engine Swap
Joined
Jan 13, 2014
Messages
323
Reaction score
7
Points
18
Vehicle Year
2002
Make / Model
Ford
Engine Size
5.0
Transmission
Automatic
ABS module won't need any plumbing, the electronics block swaps out while leaving the valve block alone.

G-Force sensor is under driver's seat if I remember correctly.
 

Andrew.V

Member
Joined
Sep 5, 2017
Messages
43
Reaction score
1
Points
8
Location
Manitoba Canada
Vehicle Year
2008 fx4
1988
Make / Model
Ford
Engine Size
4.0 5.0 2.5
Transmission
Automatic
Ok cool thank you for the help Ill try and rip into it this weekend its suppose to warm up a bit only -19 better then -30. makes pulling part off nicer out side. Was planning on pulling the Eddie bauer seats out anyway so that works out good. Ill try and up date you on how it goes on Monday.
 

Andrew.V

Member
Joined
Sep 5, 2017
Messages
43
Reaction score
1
Points
8
Location
Manitoba Canada
Vehicle Year
2008 fx4
1988
Make / Model
Ford
Engine Size
4.0 5.0 2.5
Transmission
Automatic
so update plugged the abs module in and the speedo seams to be working haven't tested the cruise yet. Thanks for the help
 

Andrew.V

Member
Joined
Sep 5, 2017
Messages
43
Reaction score
1
Points
8
Location
Manitoba Canada
Vehicle Year
2008 fx4
1988
Make / Model
Ford
Engine Size
4.0 5.0 2.5
Transmission
Automatic
update got cruise to work looped the brake pressure switch in the engine bay. new problem truck wont go over 50 km/h (30 miles/h) tried it for the first time on the weekend its like it hits a fuel cut but it has 65 psi when it happens spec is 57-70. revs up bogs out keeps doing that unless I lift. revs free in park all the way to 5000rpm. only code it has for engine are evap codes. has abs codes for front speed sensor and acceleration sensor. from what I've read none of those should matter. I've tried unplugging the maf it dosn't make a big difference any tips would be appreciated
 

fastpakr

Forum Staff Member
Forum Moderator
U.S. Military - Veteran
V8 Engine Swap
TRS 20th Anniversary
Joined
Aug 6, 2007
Messages
5,066
Reaction score
438
Points
83
Location
Roanoke, VA
Vehicle Year
1999
Make / Model
Ford
Engine Type
V8
Engine Size
5.0
Transmission
Automatic
2WD / 4WD
4WD
Tire Size
285/75-16
It shouldn't be able to rev that high in park - ought to cut at 3000 rpm. What rpm are you hitting when it cuts out in drive? Also, stupid question but you're not in low range are you?
 

Andrew.V

Member
Joined
Sep 5, 2017
Messages
43
Reaction score
1
Points
8
Location
Manitoba Canada
Vehicle Year
2008 fx4
1988
Make / Model
Ford
Engine Size
4.0 5.0 2.5
Transmission
Automatic
OK didn't know that there was a cut at 3000 in park interesting. depend on the gear you hit 50 in. it does it in first, second, reverse tried that just to see does not matter. fair question on the 4x4 thing but my truck is 2wd. best way to explain the cut is you know the was a big supercharged engine surges and almost stall at idle that's whats happening at 50. truck feels like it has a erratic miss but not to worried about that think it might be the plugs being fouled out.
 


Top