• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

1995 B4000 SE 4x4 - OBD 2 codes displayed


tangoyankee

New Member
Joined
Oct 9, 2014
Messages
5
Reaction score
0
Points
1
Location
North Carolina
Vehicle Year
1995
Make / Model
Mazda B4000 SE
Engine Type
4.0 V6
Engine Size
4.0 L
Transmission
Manual
2WD / 4WD
4WD
Tire Size
235/75r15
I plugged my OBD 2 scanner into the plug on my 1995 B4000 SE 4x4 4.0 OHV
I got these codes:

P0500 Vehicle Speed Sensor A Malfunction
P0141 O2 sensor Heater Malfunction B1 S1
P0155 O2 sensor Heater Malfunction B2 S1
P1151 Lack of upstream heated O2 sensor _______switch; indicates lean bank 2 (Ford specific code)

P0401 EGR flow insufficient

so question 1:
Supposedly my truck is not OBD 2 compliant. But it has these codes. So why is that???

Question 2: does anyone have experience repairing these issues on this vintage Ranger or B-4000???
(my speedometer has never worked since I’ve owned the truck; is that due to the speed sensor malfunction?)
 


Rock Auto 5% Discount Code: F9A1A579ACFAD1: October 1st, 2021

Dirtman

Former Middleweight Moss Fighting Champion
Supporting Member
Joined
May 28, 2018
Messages
19,344
Reaction score
13,273
Points
113
Location
41N 75W
Vehicle Year
2009
Engine Type
2.3 (4 Cylinder)
Transmission
Automatic
2WD / 4WD
2WD
Total Lift
It's up there.
Total Drop
It's down there.
Tire Size
Round.
My credo
I poop in the furnace.
I plugged my OBD 2 scanner into the plug on my 1995 B4000 SE 4x4 4.0 OHV
I got these codes:

P0500 Vehicle Speed Sensor A Malfunction
P0141 O2 sensor Heater Malfunction B1 S1
P0155 O2 sensor Heater Malfunction B2 S1
P1151 Lack of upstream heated O2 sensor _______switch; indicates lean bank 2 (Ford specific code)

P0401 EGR flow insufficient

so question 1:
Supposedly my truck is not OBD 2 compliant. But it has these codes. So why is that???

Question 2: does anyone have experience repairing these issues on this vintage Ranger or B-4000???
(my speedometer has never worked since I’ve owned the truck; is that due to the speed sensor malfunction?)
OBD2 was federally mandated in 1996 that doesn't mean nothing was using OBD2 before that. Ford/Mazda trucks were OBD2 compliant in 1995.
 

tangoyankee

New Member
Joined
Oct 9, 2014
Messages
5
Reaction score
0
Points
1
Location
North Carolina
Vehicle Year
1995
Make / Model
Mazda B4000 SE
Engine Type
4.0 V6
Engine Size
4.0 L
Transmission
Manual
2WD / 4WD
4WD
Tire Size
235/75r15
Thanks. Good info
 

tangoyankee

New Member
Joined
Oct 9, 2014
Messages
5
Reaction score
0
Points
1
Location
North Carolina
Vehicle Year
1995
Make / Model
Mazda B4000 SE
Engine Type
4.0 V6
Engine Size
4.0 L
Transmission
Manual
2WD / 4WD
4WD
Tire Size
235/75r15
OBD2 was federally mandated in 1996 that doesn't mean nothing was using OBD2 before that. Ford/Mazda trucks were OBD2 compliant in 1995.
Thanks
 

Broosedamoose

Active Member
Joined
Mar 10, 2012
Messages
218
Reaction score
31
Points
28
Location
South East Massachusettes
Vehicle Year
2007
Make / Model
Ford
Engine Type
4.0 V6
Engine Size
4.0L SOHC
Transmission
Automatic
2WD / 4WD
4WD
Tire Size
31 x 10.5
My credo
Coming in second just makes you the first loser!
Sounds like you need to check the connection on the Speed Sensor and if it's good then you need to replace it. Also sounds like you need to replace your O2 sensors. It's best to replace them all at the same time.
 

tangoyankee

New Member
Joined
Oct 9, 2014
Messages
5
Reaction score
0
Points
1
Location
North Carolina
Vehicle Year
1995
Make / Model
Mazda B4000 SE
Engine Type
4.0 V6
Engine Size
4.0 L
Transmission
Manual
2WD / 4WD
4WD
Tire Size
235/75r15
Sounds like you need to check the connection on the Speed Sensor and if it's good then you need to replace it. Also sounds like you need to replace your O2 sensors. It's best to replace them all at the same time.
Where is that speed sensor located on a 95 b4000 4x4? Or Ranger 4x4
 

tangoyankee

New Member
Joined
Oct 9, 2014
Messages
5
Reaction score
0
Points
1
Location
North Carolina
Vehicle Year
1995
Make / Model
Mazda B4000 SE
Engine Type
4.0 V6
Engine Size
4.0 L
Transmission
Manual
2WD / 4WD
4WD
Tire Size
235/75r15
Sounds like you need to check the connection on the Speed Sensor and if it's good then you need to replace it. Also sounds like you need to replace your O2 sensors. It's best to replace them all at the same time.
Replaced the two O2 sensors referenced. I still have all of the same codes after a week of driving. Checking wiring today. Any other advice is welcome.
 

fastpakr

Forum Staff Member
Forum Moderator
Article Contributor
U.S. Military - Veteran
V8 Engine Swap
TRS 20th Anniversary
TRS Event Participant
Joined
Aug 6, 2007
Messages
6,660
Reaction score
1,566
Points
113
Location
Roanoke, VA
Vehicle Year
1999
Make / Model
Ford
Engine Type
V8
Engine Size
5.0
Transmission
Automatic
2WD / 4WD
4WD
Tire Size
285/75-16
If you can find a wiring diagram for your '95, I'd grab a volt meter and see if you're getting power on the appropriate wire for heating the upstream O2 sensors.
 


Top