• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

1994 ranger randomly won't start


Grizzly_bradams

New Member
Joined
Dec 13, 2014
Messages
3
Reaction score
0
Points
0
Location
Georgia
Vehicle Year
1994
Make / Model
Ford
Engine Size
3.0 L
Transmission
Manual
I have a 1994 Ford Ranger 4x4 single cab with a 3.0 liter V6 and a manual 5 speed transmission. I've been having a few odd electrical problems in the past few months and I just can't quite find the root of it all. The truck runs great, idles smooth, and never skips a beat, however, every so often, could be ten times in a day, could be once every couple days, it just plain won't start. It'll turn over, but the fuel pump does not turn on and I don't believe that it's not getting enough fire. At first, the only way to start it would be to use starting fluid and run it at high RPMs for about ten seconds, and then the fuel pump would turn on. That no longer works to start it. At first, I thought it was just a fuel pump relay, so I went through about 5 of them, each one busted, and that didn't quite solve it. Then I figured the ground wire from the battery may not be quite heavy enough, so I added a 2 gauge ground to it. That solved it for a few days. Then it started happening again, so I had the battery tested, and found that it was bad. That really surprised me because it was a rather heavy duty battery purchased six months ago. I replaced the battery, and believe it or not, that solved the issue for about a week, and no relays were blown. I no longer blow relays, but now whenever the truck won't start, I have to disconnect the hot terminal on the battery and leave it off for about five minutes, then I'll put it back, and it'll run like nothing happened. I'm thinking it's my computer, but I'm hoping someone else has had this issue before and knows how to fix it. Thanks for reading.
 


Rock Auto 5% Discount Code: F9A1A579ACFAD1: October 1st, 2021

TxGasRacer

Member
U.S. Military - Veteran
Joined
Oct 17, 2011
Messages
170
Reaction score
2
Points
18
Age
67
Location
SE Texas
Vehicle Year
1998
Make / Model
Ranger
Engine Type
4.0 V6
Engine Size
4.0 ohv
Transmission
Automatic
2WD / 4WD
2WD

black_demon69

Well-Known Member
Joined
Jun 30, 2013
Messages
1,460
Reaction score
99
Points
48
Location
AZ
Vehicle Year
1994
Make / Model
Ford
Engine Type
4.0 V6
Engine Size
4.0l
Transmission
Manual
2WD / 4WD
4WD
listen to the jedi master young padawan:D

had the same issue after fuel pump was replaced with an airtex (yuk) at car lot 2 days after i bought it (they did it for free) i chased the problem for months and finally was able to get a diagnosis when it happened at the house where i had tools. turned out airtex pump was junk from the start so i replaced with a carter from pepboys and have not had a problem since....
 


Top