• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

1990 2.9L 2WD issue with sudden motor drop-off as I'm at speed 65mph...?

Erikinho

New Member
Joined
Aug 22, 2022
Messages
18
Reaction score
0
Points
1
Location
Chula Vista, Ca.
Vehicle Year
1990
Make / Model
Ranger ECAB
Engine Type
2.9 V6
Transmission
Automatic
2WD / 4WD
2WD
My credo
"Be quick to listen and slow to anger"
So, when I'm running along the freeway, the engine drops off in a fraction of a second but reengages!? It's a bit alarming... I spoke to my mechanic and he thinks it's the TPS module...? (I just remembered the TPS REPORTS from OFFICE SPACE film LOL!)
What's been your issues and fixes with this? Thanks!
 


RonD

Well-Known Member
Joined
Jun 2, 2012
Messages
22,925
Reaction score
5,991
Points
113
Location
canada
Vehicle Year
1994
Make / Model
Ford
Transmission
Manual
Its possible TPS has a Dead Spot, but you should notice that at any speed when gas pedal is in that one position
TPS is a 5volt sensor on the throttle plate shaft
With throttle closed computer gets just under 1volt from the TPS
With throttle wide open(WOT) the computer gets 4.5volts
So it works the same as a volume control or light dimmer, a variable resistor

If there is a "dead spot", voltage drops to 0 or under 1 volt in that one position, so computer "thinks" you took your foot off the gas pedal, and if you didn't then an unexpected stumble
But at 30mph or 60mph, speed wouldn't matter only TPS/gas pedal position would matter

RPM stumble, spark system
Again this should occur based on RPM of the engine not speed, so if its distributor or TFI issue you would expect the stumble in 1st, 2nd, or 3rd gear when at that RPM


At 60+MPH fuel flow would be at its highest, unlike 30MPH, or say 2,500rpm in 2nd
So fuel flow issue would fit better
Change fuel filter
Check fuel pressure at idle, 30psi is expected, then REV engine to 2,500(approx.) and hold it there, watch to see if pressure is slowly dropping, should stay stable at 30psi, if its slowly dropping there is a flow issue, which would be much more noticeable with engine under a load(driving)
 
Last edited:

Erikinho

New Member
Joined
Aug 22, 2022
Messages
18
Reaction score
0
Points
1
Location
Chula Vista, Ca.
Vehicle Year
1990
Make / Model
Ranger ECAB
Engine Type
2.9 V6
Transmission
Automatic
2WD / 4WD
2WD
My credo
"Be quick to listen and slow to anger"
Thank you very much RonD! I will try your advice!
 

Erikinho

New Member
Joined
Aug 22, 2022
Messages
18
Reaction score
0
Points
1
Location
Chula Vista, Ca.
Vehicle Year
1990
Make / Model
Ranger ECAB
Engine Type
2.9 V6
Transmission
Automatic
2WD / 4WD
2WD
My credo
"Be quick to listen and slow to anger"
So, here's the latest... I replaced the fuel filter and the TPS module...The engine still hesitates when I depress the throttle...? I'm going to use an injector cleaner in the fuel and see what that does...? Any suggestions...? The car starts quickly, idles perfectly... But, it's the depressing of the accelerator pedal that the problem occurs...?
 

rusty ol ranger

Im a Jeep guy now.
Supporting Member
Joined
Sep 22, 2007
Messages
9,853
Reaction score
4,822
Points
113
Location
Michigan
Vehicle Year
1987
Make / Model
Ford
Engine Type
2.9 V6
Engine Size
177 CID
Transmission
Manual
2WD / 4WD
2WD
My credo
A legend to the old man, a hero to the child...
Check the fuel pressure...should be at 40lbs or thereabouts.

Could also be a vacuum leak. Or possibly a MAP sensor. Try pulling codes, you might get lucky. Is your check engine on?
 

Erikinho

New Member
Joined
Aug 22, 2022
Messages
18
Reaction score
0
Points
1
Location
Chula Vista, Ca.
Vehicle Year
1990
Make / Model
Ranger ECAB
Engine Type
2.9 V6
Transmission
Automatic
2WD / 4WD
2WD
My credo
"Be quick to listen and slow to anger"
Check the fuel pressure...should be at 40lbs or thereabouts.

Could also be a vacuum leak. Or possibly a MAP sensor. Try pulling codes, you might get lucky. Is your check engine on?
How do I pull codes...?
 

rusty ol ranger

Im a Jeep guy now.
Supporting Member
Joined
Sep 22, 2007
Messages
9,853
Reaction score
4,822
Points
113
Location
Michigan
Vehicle Year
1987
Make / Model
Ford
Engine Type
2.9 V6
Engine Size
177 CID
Transmission
Manual
2WD / 4WD
2WD
My credo
A legend to the old man, a hero to the child...
How do I pull codes...?
With this...

Or a test light...but i prefer the reader, makes it much simpler.

Theres instructions all over online how to do it and the reader comes with a pretty cut and dried book thatll explain it.

The code port is under the hood, passenger side corner by the blower motor, itll say "eec test" on the cover. Its basically just a pigtail of wires
 

Sponsored Ad


Sponsored Ad

Top