• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

1986-1988 factory tachometer option

EVOrider

New Member
Joined
Sep 8, 2008
Messages
25
Reaction score
1
Points
3
Vehicle Year
1983
Make / Model
Ford
Transmission
Manual
I have purchased a instrument cluster with the tachometer from a 1987 Ford Ranger that had the 2.9L. For $10, what the heck!

I have installed the cluster into my 1983 Ranger. However, I have been unable to get the tach to work. I wired it in just like the 1987 wiring diagram.

It is wired from pin 4 from the computer with the resistor in the wiring. It is then wired into the green wire from the coil. From there, it goes to the instrument cluster. There is also a ground wire from the cluster to a ground near the coil. This has all been done.

I have not rewired from the Amp gauge to the battery light yet. Does anyone know if this might be why the tachometer is not working.

Any ideas.....
 


Rock Auto 5% Discount Code: BD8D9A3814E19D Expires July 5th, 2022

enginepaul

Member
Joined
Aug 7, 2007
Messages
425
Reaction score
9
Points
18
Location
Northern California
Vehicle Year
1995, 2001, 200
Make / Model
Ford
Engine Size
2.8
Transmission
Automatic
Not sure of your exact problem but I couldn't get a tach to work with the TFI. I bought a transformer that is supposed to help, but haven't installed it. The TFI ignition is the problem.
 

dangerranger83

5.0 HO under the hood!!!
Supporting Member
V8 Engine Swap
Solid Axle Swap
Joined
Apr 26, 2009
Messages
7,999
Reaction score
54
Points
0
Location
Lafayette, IN
Vehicle Year
1983
Make / Model
Ford
Engine Size
5.0 HO carbed with an np435 and np208
Transmission
Manual
I had an aftermarket tach work fine for me but it never hooked to the computer. It had green to coil, power key on, ground and hooked to my fuse pannel for the back light in it to turn on when my headlights turned on.


But a clutch change way back changed that as it now reads what it wants to and I havent had time to get under and look at what the problem is.


See if yours is getting power and not on a wire that isnt being used but is in the wiring harness.
 

EVOrider

New Member
Joined
Sep 8, 2008
Messages
25
Reaction score
1
Points
3
Vehicle Year
1983
Make / Model
Ford
Transmission
Manual
I managed to get the tachometer to function now....

I will eventually change out the oil sender for the oil light. The trucks use two different oil senders...one for the trucks equipped with the oil light and one for the guage. Once this is changed, the oil light will work.

I also have not changed the wiring off the alternator and voltage regulator so the charging light will work.

I also lost the seatbelt light and the brake light as well. I could have kept these if I also changed out the panel. But, I preferred to keep the 1983-1985 era.

For now, I am using the post on the back of the cluster for powering the tachometer. Once the alternator and voltage regulator are rewired for the charging light....the tachometer will be powered through the terminal.
 

dangerranger83

5.0 HO under the hood!!!
Supporting Member
V8 Engine Swap
Solid Axle Swap
Joined
Apr 26, 2009
Messages
7,999
Reaction score
54
Points
0
Location
Lafayette, IN
Vehicle Year
1983
Make / Model
Ford
Engine Size
5.0 HO carbed with an np435 and np208
Transmission
Manual
I would keep a brake light personally, I have had mine tell me a few times there was a problem before I went to drive the truck.
 

Sponsored Ad


Sponsored Ad

Top