• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

o2 sensor


  1. 2.5L ('98-'01) O2 sensor heating element Issue, 1998 Ranger 2.5L

    1998, 2.5L ranger, 2WD, manual So I have had issues with the upstream O2 sensor since i got the truck over a year and a half ago. I dont exactly remember when it started throwing a code for it, maybe right after I bought it, certainly not long after I bought it. It seemed like it used to get...
  2. Pesky P1131 on B2500

    Hello Everyone, First time posting, but I have been reading and getting a lot of help from here for awhile. I have a 2000 Mazda b2500 4 Cylinder 2.5L Manual with a P1131 code. My understanding of this code is that it is a lean reading at the upstream o2 sensor. Noticeable symptoms are...
  3. 87. Blues

    Ive puchased a 86/...or87 depends on if you go by tube door fenders or the paper work ...man i lucked up on this no rust dings dents .....or not a tear in the cloth seats ....pretty lil baby blue truck.its a 2.9. V6. Automatic i had it about 2mnths ....and couldn't ask for a better truck but now...
  4. kwheat4136

    Emissions system problem?!??

    I recently bought 2000 Ranger XLT 2.5L 4 CYL 5 speed manual. 145700 miles. Runs great most of the time. I've discovered that when it is idling at startup (the usual higher RPM), if I quickly rev it to bring the idle down it becomes very rough running (almost like it's too rich) and won't stay...
  5. Johnny Creeps

    No codes

    My truck, 94 4.0L Ranger, runs like perfection, then when I put it in park, it dies. When I restart it, the check engine light comes on (but I can't get it to flash codes for me) and it chugs and is dumping gas into the system. To me, it was obviously the O2 sensors... changed both of those...
  6. O2 Sensor questions

    I have a 1990 2.9L Ranger that has 268K miles on it and I know that the o2 sensors have never been replaced. I can only find one right before the cat. Is there any others on this engine or is that the only one. And since the vehicle is "broken in" could the o2 sensor go bad or malfunction...
  7. o2 sensor replacement trouble (bank 1 sensor 1)

    I'm getting a P0133 so I need to replace the passenger side upstream o2 sensor (bank 1 sensor 1). I replaced the driver side one a few months ago with no problems. The passenger side one however seems really difficult to get at. It is just above the cat and faces upwards towards the underside of...
  8. 4.0 Blown ECM

    So not too long ago I finished changing the 4.0 in my '93 4x4 ranger. The engine I got to replace it was from a '92 ranger. The only visible difference I could see when I swapped the two was that the '92 had 1 O2 sensor and the '93 had 2 O2 sensors. After I got everything connected it...
  9. Spark plug problems

    Help! I have an on going problem with my 2000 Ford Ranger 4.0 ltr, V6. Usually the number 4 cylinder needs replacing due to a cracked porcelain base. The last time it had a lot of oil around it. Now the codes PO174, P1151, PO306, and Cat fault are coming up. The engine light remains on...
  10. Misfires on warm start?

    Hey everybody, really been enjoying reading all the information here. I bought a lovely 2001 3.0L XLT with flare sides about a year ago and our relationship has been on the rocks for the past few weeks. I'm getting conflicting signals and not sure really what's going on. I'm having rough...
  11. 91 ranger ROUGH/DYING idle, STRONG gas smell under hood, gas dripping from headers

    91 ford ranger 2.9 The other day on a 3 hour road trip the check engine light came on for 15 minutes, and then shut off for the rest of the trip. While driving the other night it came back on; no real loss of power just seemed to be a slight "caming" effect at idle. I ran the obd1 self test...
  12. Bish0psaid

    Where does this wire go?

    So this o2 sensor is on the outside of my Exhaust manifold and the burnt wire I can not find where it plugs in at? I can see where my other 2 are connected on my pipe before and after the cat, but this one baffles me, I have a 95 Ranger XLT 2.3L 227,*** miles, I tried google and lookin' in a...


Top