• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

bronco ii

  1. Ikesbronciasaurus

    Bronco ii 87 2.9 runs for 15 minutes until starts ticking loud!

    Hey guys been trying to get my bronco 2 started for about a month Finally got her started just needed a new ecm relay! After decided to change out a lot of ignition part along the way! excited BUT she is doing the same thing she has done for three years now that’s it’s running. She runs for...
  2. A4LD_Nghtme

    RABS CODE 4 Both brake lights on 90 Bii

    Hey there, I have a 1990 Bronco II XLT 4x4 that has been edging ever closer to finish. I've recently replaced the brakes almost in their entirety for the rear and still after bleeding the entire system have both the yellow and red brake lights illuminated and I now have a flashout CODE 4...
  3. Help needed with front axle and diff disassembly

    Hello, I am currently restoring my Bronco II '88. I'm trying to take the front axle and diff apart due to the fact that 4wd doesn't work and movement of steering causes strange noises. When I tried to take it apart I couldn't get past the removal of the spindle, it seems to be stuck. Do you have...
  4. A4LD_Nghtme

    1990 Bii 2.9 FAILED CA SMOG!

    Hey there all! I just got back from a failed smog test. As you can see I got a pass on everything except my HC ppm at 15 mph and my NO ppm at both 15 and 25 mph. It has a fresh new o2 sensor and last i checked i had no codes. And they passed me on the OBD system check. I have not replaced the...
  5. A4LD_Nghtme

    Transfer case end spraying fluid on undercarriage? SOLVED!!!

    Hey there. 1990 Bii project trying to get to body restore but I'm having 4x4 and apparently transfer case end issue. If you check the attached photo, it appears that I have a leak at what I assume is the rubber piece and it's spraying my undercarriage something fierce. Any idea what the part is...
  6. A4LD_Nghtme

    4X4 does not engage at all after new transfer case motor. SOLVED!!!

    Hello! I swapped out my 4x4 transfer case motor on my 1990 Bronco II XLT and I now have no lights at the dash at all and zero control module actuation. Before the swap the lights would come on for both 4 Hi and 4 Lo and the you could hear the 4x4 control module function. Now there is zero...
  7. A4LD_Nghtme

    1990 2.9 open port on engine near Oil Sender. SOLVED!!!

    What is this opening on my 2.9? I got down there to clean and change the oil sender unit and noticed there's a deeply recessed port. Not sure if it's the norm and I'm just overreacting but I don't want to run to pick n pull to check without asking first. Any clue what this is and if there should...
  8. A4LD_Nghtme

    What are these connectors on my 90 Bronco II? SOLVED!!!

    Have some connectors unplugged with no wires dangling for an idea what they are. One is in the engine compartment next to the harness with light blue wires. Appears to go to VSS based on a manual 89 so I grabbed that cable but mine has dark green/white and orange wires on its vss connector with...
  9. A4LD_Nghtme

    1990 Bii A4LD Valve Body rebuild with ZERO engagement. SOLVED!!!

    Hey there all!!! I've officially searched through this site, FTE, and even explorer forums(posted this on there too) but still can't find a straight answer as to a possible problem with my trans. Here is what I changed: Transtec valve body gaskets. Transgo and Superior Shift kit combined. Sonnax...
  10. Bad spark

    Hi, I’ve got a 1988 Ford bronco ii. It’s running like sh*t. I’m not sure exactly where I’m at with it. As in I’m not sure if any of the new parts I’ve put in are marking the problem worse, or if the bad part is getting worse over time. The spark from the coil to the distributor seems ok. The...
  11. 1988 Bronco II - No reverse lights, new NSS switch and starting in all gears

    Ok so I have no revers lights in my Bronco II - A4LD trans and 4x4. I first replaced the NSS thnking that was the issue - still no lights. Also its starting in all gear positions now. Will get to that later.... As far as the light issue goes - I Tested Purple/Orange wire in harness and have...
  12. Vibration/grinding noise

    Hi, I've got a 1987 Bronco II. It's a 2 wheel drive. It runs and drives well. When I bought the truck. It had a pretty bad grinding noise when I would go from stop at a red light to take off. I figured it was either sticking brakes or the transmission. I checked the brakes, but they looked ok. I...
  13. Injectors not seated?

    Hi guys, new heads on a 1986 2.9L Bronco 2. The new injectors on the passenger side don't seem to sit as far down as the drivers side. We unbolted and rebolted the fuel rail a few times and we can't seem to get the passenger side injectors to go down any lower with or without the fuel rail being...
  14. DingleBerry Handpump

    What Sway Bar Links are compatible with Bronco II 6in lift

    I'm looking for Sway Bar Links that are compatible with a 1990 Ford Bronco II with a 6in. Lift any suggestions? Thank you
  15. 1989 Bronco II hard brake lines

    Is there a difference between 1989 & 1990 Bronco II hard lines? Conducting a brake job that is becoming a restoration project... The only preformed lined are up to 88 & 90 w/abs. Advice and input is very much appreciated at this point. Thanks in advance.
  16. Pix3L8

    thoughts on high-idle

    Hey guys, so since my last post, I got my 2.9 put back together, in the truck, and it's running like a champ, purring like a kitten. You see the only issue that I'm having, which as I understand, is a 2.9 "thing" is that my idle won't go down no matter what I do to it. If I start the truck and...
  17. A4LD to M5OD swap?

    Hello! I'm pretty new here, so I hope I'm posting in the correct thread. TLDR: A4ld went out, want to find a M5OD to swap in. Skip to the "CONCLUSION" if you don't want the full story. I was given a 1990 Bronco II by my Grandpa, it's sort of been a family vehicle for a long time. I drove it...
  18. More problems with the 2.9 idle dropping

    Well my problems came back after running good for a month, My 1988 bronco ii 5 speed had a loose ground causing it to buck and surge. Well this month my bronco ii started running worse then ever it would start missing and would idle low at a stop sign then finally come to a complete stall. It...
  19. Ford 2.9 Weird unexplained issue

    Hello ranger station i recently bought a 1988 bronco ii 2.9 5 speed that had been running like crap, My issue is when warm my truck idle surges at around 400-550 sometimes if i give it throttle it will go back to 900. (this sucks when driving in town and stop and go traffic on hills) it feels...
  20. The $350 Immaculate Bronco II

    An introduction to me and my second recently acquired Bronco II- I might have found the greatest deal on any Bronco II, ever. It was purchased in 1990 to be towed behind and RV, and only got about 50,000 of actual road time before I got it a few days ago for $350... with 157k on the odo. It...

Sponsored Ad


Sponsored Ad

Top