• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' the posts that you read.

Search results


  1. (NE Ohio) 99 Ranger 4x4 3.0, Auto, 96,xxx miles

    Seeing if any interest from someone who could use it. I can post pictures if there is interest. The point has come to part with "The Golden Beast". Has check engine light (supposed to be wiring issue near the rear along frame), broken shackle on driver's side, rear ABS sensor is bad (I have a...
  2. Fuel Pump Replaced and it still doesn't start

    Noid light was 8.99 at Auto zone. Works on blowers blowers tiller...... must have IMHO. RonD its starting to sound eerily similar to the TPS issue I had. RangerRick, If you have spark on all cylinders(even one) the crank sensor is good. I would check the voltage from the TPS to the PCM...
  3. Fuel Pump Replaced and it still doesn't start

    Throw in some starting fluid? Sent from my DROID RAZR using Tapatalk
  4. Truck won't start, and I can't figure out why....

    ('99 3.0 FFV) It seems like everything is in place for my truck to start, but doesn't. It cranks, and starts maybe every 3rd or 4th day during my diagnostics. The problems started after one night of bad weather (ran to store for wife's ice cream..... the essentials). Came home and no go a week...
  5. Another CPS horror story...with a twist.

    FML...... Tonight on my way home the camshaft gave up the ghost. 99 with 90,000 miles on it.. The twist. I replaced the camshaft complete about 12,000 miles ago as preventative maintainence. Yes, a Motorcraft part. No chirping then and none except right before the pressure dropped. Chipped and...
  6. Knock in Steering Rack (99 XLT 4x4)

    I have a knock that is coming from the rack. Found it by having my wife jump on my steps and felt it in the steering linkage. No leaks, fluid flushed and no air trapped... The outter end is moog, newer and greased....so I replaced the inner with a moog and the problem is still there. I'm...


Top