• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Search results

  1. clockdore

    Engine racing at idle

    If I disconnect the IAC, nothing changes. If I disconnect the TPS, it revs higher.
  2. clockdore

    Engine racing at idle

    I'm having the same issue. Worked fine until yesterday. I took out the IAC and sprayed the piston with cleaner, replaced the o-ring between the motor and the piston. Started up and idled fine. When to the store and when leaving, high idle. So I just took it out again and made sure...
  3. clockdore

    Engine racing at idle

    Acting up again.
  4. clockdore

    Engine racing at idle

    Excellent! This morning cold start, it was in the lower 60's, chilly for here, rpm shot right up pretty high, "oh oh", paused, then started creeping back down, stumbled once and almost stalled, then bumped it up a little. It's learning. Sat for a couple hours at the park, beautiful day today...
  5. clockdore

    Engine racing at idle

    If it's original, it is 30 years old!
  6. clockdore

    Engine racing at idle

    I'm curious. They had it in the shop for 2 1/2 days doing the AC. Why would they remove the IAC? It's not in the way. Either they removed it and overlooked the bottom bolt, or someone deliberately loosened it. I just can't figure it. It's a big shop, maybe four full time mechanics, maybe...
  7. clockdore

    Engine racing at idle

    After sitting for a few hours, I just started it to go to the car wash, it high idled for a few seconds, then backed down to the appropriate idle. It didn't race, just high idle, exactly what I would expect.
  8. clockdore

    Engine racing at idle

    This morning it idled fine from a cold start. On my way, the idle increased a little bit, then it was good when I got to my destination. When I started again when I left, it shot right up high then immediately backed down. It has been fine since. I think I'll just leave it alone for now. I...
  9. clockdore

    Engine racing at idle

    When I unplugged the IAC, the idle was already low. I'm going to replace the tube and the IAC, but I have to wait until Wednesday when I get my deposit. A new tube is $50+. I think I'll go t a u-pull-it and find one for a couple dollars. The IAC is $60+. It just seems odd that that part...
  10. clockdore

    Engine racing at idle

    My 1994 Ranger was having idle issues, idling real high after AC replaced. I replaced the TPS sensor, and it's been fine for about a week. Then today, Started ok, went to the store and when I started it to leave, it's racing again. I got almost home and shut it off and started it again, it's...

Sponsored Ad


Sponsored Ad

Top