• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Search results

  1. 1993 4x4 rear axle differential vent valve

    Thanks for all of the input. Sorry for the delay in getting back with results. Life got in the way and I was only able to inpsect the vent this weekend. The hose and vent are both clear. I have to assume the ABS sensor was not properly seated and there was enough pressure built up to blow out...
  2. 1993 4x4 rear axle differential vent valve

    The morning after a 90 mile round trip I found a puddle of differential fluid on my driveway. Upon inspection, it appears that the pressure built up and blew out the ABS sensor on the axle. Not completely but that is obviously where the fluid was coming from. That had recently been replaced. Is...
  3. Added tow hooks to my '93

    I wanted to give a shout out to @Jim Oaks for posting the article by Chris Warren about adding tow hooks. Thank you sir. The parts list was spot on. I just picked up my 1993 a month ago or so and wanted to add them but wasn't sure where to start. I don't have the valance with the fog lamps so I...
  4. serpentine belt wont go on

    Thanks. I had to get a larger belt. The previous owner replaced the a/c compressor and it must have a larger pulley than stock. 88.78” belt went on in minutes.
  5. serpentine belt wont go on

    Nah. I just sold the 88 and didn’t update my profile.
  6. serpentine belt wont go on

    I need some help. What should have been a 10 min job turned into a few hours and still no luck. I have a 1993 XLT with 4.0 and AC. I got two different serpentine belts from AutoZone but I can't get either of them on. They seem to be about an inch too short. I can't get the edge close enough to a...
  7. 2.9 L misfire above 2200 RPM - Is my MAP sensor bad?

    Thanks. I had checked the timing the other day and it seemed fine. When you say secondary ignition system what are you referring to? I recently replaced cap, rotor, plugs, wires. Is there a way to test the coil?
  8. 2.9 L misfire above 2200 RPM - Is my MAP sensor bad?

    So I woke up in the middle of the night and realized, that code 18 was probably left over from the broken alternator wire I fixed prior to picking up a code reader. That was also prior to the misfire starting. I cleared the code, (which I didn't realize I had to do) after reading further into...
  9. 2.9 L misfire above 2200 RPM - Is my MAP sensor bad?

    Vacuum is good. Still getting a code 18 with key off. key on there are no codes.
  10. 2.9 L misfire above 2200 RPM - Is my MAP sensor bad?

    Will do. I'll have to borrow a vacuum gage. what reading should I get from that?
  11. 2.9 L misfire above 2200 RPM - Is my MAP sensor bad?

    It had a code 18. I cleaned up the bare spout ground wire and re-wrapped the wire. No codes after that. I suppose I should try the code reader again?
  12. 2.9 L misfire above 2200 RPM - Is my MAP sensor bad?

    My 1988 2.9L idles fine. When I get it up over 2,200 rpm it will start to misfire. I have a question about how a MAP sensor is supposed to act. I'm getting 5v on the power wire. 2.3v on the signal wire with the key on, motor off. If I start the motor, the signal wire stays at 2.3v even when I...
  13. I hate to just throw parts at this but I don't know what I'm looking for at this point and my...

    I hate to just throw parts at this but I don't know what I'm looking for at this point and my local garage replace the fuel pressure regulator and told me the misfire was likely caused by too much fuel being delivered and should clear up on it's own with the new one installed. I'm not buying...
  14. Greetings franklin2. I'm jumping off the original thread that you responded to my question. I...

    Greetings franklin2. I'm jumping off the original thread that you responded to my question. I didn't want to highjack that one. It was on the BroncoII 2.9 code 18. I checked the timing and it was fine. I cleaned up the bare ground wire from the TFI and the code 18 went away. I had recently...
  15. 1986 Bronco II 2.9 code 18

    Following this thread because I have a similar issue. The stalling happens occasionally, it seems to idle fine, I'm getting what I believe is a miss fire when the RPMs are over 2200. I found the insulated wires and there was some corrosion at several spots on the bare ground wire. That doesn't...

Sponsored Ad


Sponsored Ad

Top