• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Search results

  1. 2.3L ('83-'97) CEL from lack of EGR

    Wondering if anyone can help me with this: I swapped a 5 speed into my 93 long bed 2.3 ranger, and along with the swap I put in a ECU from a 93 or 94 5 speed truck. I believe my ranger never came with EGR because I don't see any wiring, and I'm missing all the EGR parts. A couple people on this...
  2. 2.3L ('83-'97) 2.3 Bad Gas Milage

    Thanks for the response. Tires are 225/70/r15, I haven’t checked the odometer but i’ve verified that the speedometer is accurate (tested against gps speedometer) and I believe those two are mechanically linked. No codes beyond the two I listed. The exhaust past the cat is new, and the cat flows...
  3. 2.3L ('83-'97) 2.3 Bad Gas Milage

    So I bought this 2.3 2wd long bed ranger over a year ago with the intent of putting a lot of highway miles on it. I spend the winter swapping the transmission to a 5 speed and now that its on the road this summer i’m noticing it gets really bad gas milage. I get about 18 mpg in the city and 18...
  4. 2.3L ('83-'97) Clutch Bleeding Issues After Transmission Swap

    89Twincharge and Rowdy, you were totally right. I cleaned up the input shaft and greased it and now the clutch works great. Thanks for the help
  5. 2.3L ('83-'97) Clutch Bleeding Issues After Transmission Swap

    The clutch kit is a clutchMax OEM 1995-2011 kit off ebay. Slave is also an ebay replacement that says “1995 - 1999”. The original pressure plate was a self-adjusting style and I replaced it with a non-adjusting one, though I have had the same issue with both pressure plates in the vehicle.
  6. 2.3L ('83-'97) Clutch Bleeding Issues After Transmission Swap

    Here’s a picture of the input shaft, are those lines anything to worry about? (the orange on the spline is grease, not rust)
  7. 2.3L ('83-'97) Clutch Bleeding Issues After Transmission Swap

    I have the transmission out currently and I can’t see anything wrong with the slave. It’s not leaking or anything and looks exactly the same as the replacement. The input shaft wasn’t too dirty, but I greased it up anyway just in case. Is there any compatibility issue with the parts I have? I...
  8. 2.3L ('83-'97) Clutch Bleeding Issues After Transmission Swap

    So today I disconnected the master from the slave. The clutch pedal has no movement at all when I press on it, so I think the master is fine. Then, I took my old clutch line and used it to pressure bleed the slave separately using my vacuum bleeder. Then I reconnected the two and before turning...
  9. 2.3L ('83-'97) Clutch Bleeding Issues After Transmission Swap

    I will try lifting the front of the truck next time I bleed it but something seems wrong. I may have to pull the transmission again to inspect or replace the slave.
  10. 2.3L ('83-'97) Clutch Bleeding Issues After Transmission Swap

    It doesn't make sense to me either, but that's the only way I can describe it. The clutch pedal only softens up if the engine is running. With the engine off, I can press it as many times as I want and it won't go soft. With the engine on, the clutch softens up after the first pump or two. It...
  11. 2.3L ('83-'97) Clutch Bleeding Issues After Transmission Swap

    So today I pulled the master cylinder and bench bled it as instructed. It felt good and has less than a 1/16 in of play when disconnected from the slave. I reconnected and I still have the same problem. I also rented a vacuum bleeder, no luck there either. Still the same problem, the clutch...
  12. 2.3L ('83-'97) Clutch Bleeding Issues After Transmission Swap

    I have posted here about this swap before and have narrowed my issues down to the clutch hydraulics. To recap, I swapped my 1993 2.3 2wd ranger from an a4ld automatic to a m5od-r1 manual transmission. At this point, I have dropped the transmission 3 times trying to narrow down the issues. I have...
  13. 2.3L ('83-'97) 93' 2.3 Clutch Issues After Transmission Swap

    Another weird symptom... I am able to roll the car in gear with the clutch down when the engine is off, but when I turn the engine on it wants to creep forward
  14. 2.3L ('83-'97) 93' 2.3 Clutch Issues After Transmission Swap

    I did not grease the disk splines or input shaft, or the pilot bearing for that matter. The hose from the master to slave is new, yes. It came preinstalled on the pre-bled master cylinder.
  15. 2.3L ('83-'97) 93' 2.3 Clutch Issues After Transmission Swap

    Yep that’s correct. I had a donor clutch disk and self-adjusting pressure plate. I reset the pressure plate with a press, and the clutch disk was used but had a lot of material left on it. I will try wearing down the clutch today and see if that helps. The only other thing I can think of is...
  16. 2.3L ('83-'97) 93' 2.3 Clutch Issues After Transmission Swap

    I have good clutch pressure and with the pre-bled master, I assumed there wouldn’t be any air stuck in there. I guess it can’t hurt to try
  17. 2.3L ('83-'97) 93' 2.3 Clutch Issues After Transmission Swap

    I recently converted my 93' ranger to a manual from the a4ld automatic. I'm having trouble getting the clutch to fully disconnect. When the engine is on and I go to put the truck in reverse, it grinds. The transmission goes into gear perfectly when the engine is off. I am able to start the car...
  18. Clutch won't disengage even with good pedal pressure

    Thanks for the replies, Since posting I have tried various methods of bleeding the clutch. It is possible that it's still not fully bled, but I have decent pedal pressure and I can see the pressure plate moving about 1/2 to 3/4 inch through the access hole in the transmission (about the same...
  19. 1993 Tachometer Cluster Swap

    Oops, forgot to include that. Both my truck and the donor were 1993 2.3's.

Sponsored Ad


Sponsored Ad

Top