• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Search results


  1. 2813josh

    T-case motor connectors...

    So I ordered a new tc motor from Rock Auto...the wrong one :sad:. The one I got has the single connector and the one on the truck has the sensor and another wire going to the case. My question is, should I be able to just swap the harness from the old motor or are there other differences in...
  2. 2813josh

    Need some axle help...

    Ok. so I just picked up a front diff froma 96 Exploder...thinking I could put it in my 87 BII. Now I'm thinkin I scewed up because I don't see it happening. Wonderin if I'm missing somethin...I know its a D35. So Ive been checking the tech Library and I see its SLA IFS....so am I pretty much...
  3. 2813josh

    Ecm??

    :icon_confused:87' bII idles fine, revs up fine..but when I try to drive it it bogs down really bad and every once in a while it seems to catch and run good for a few seconds. Mayybe a cat? Gas looks ok,ignition is all new except the TFI. Also does not like to start without ether..It also has...
  4. 2813josh

    Any ideas? No start

    Ok 87' BII 4x4 5spd. Oil pan was leaking really bad and the flywheel was worn down to the point that I could only start it by push start... So I decided I'd just pill the motor..new clutch,flywheel,rear main,oil pan, valve covers etc.. So anyways got it all back together and now I can't get...


Top