• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Search results


  1. SenorNoob

    SenorNoob's '88 Ext Cab "Build"

    First I just want to say: I'm starting this not a "build" thread so much as a place to pic whore, keep a record of what I've done, and ask stupid questions. (I have lot's of stupid questions.) There won't be anything wild done with this truck. Maybe with a little luck someone will find something...
  2. SenorNoob

    Y-Pipe Flange Rubbing Radius Arm End

    I've recently become aware of this problem... My question is what should I look at for the cause? Only thing I can think of is the fact that my driver's side engine mount plate came from the 2.9, but it seems to be level. Could both mounts (the rubber part) be bad causing it? For anyone...
  3. SenorNoob

    Cooling System Problems I Think

    I have what sounds kinda like an engine knock sometimes and sometimes like very large air bubbles from boiling water going on most of the time when I cut the engine off. I've never noticed anything while driving. Kinda sounds like the problem described in the Coolant By-Pass Kit TSB. Also...
  4. SenorNoob

    Explorer Axle First Gen

    I'm sure they are here somewhere but I've searched and can't find them. So, does anyone have pics of a 1st gen Ranger with the Explorer axle in the rear with stock size Explorer wheels and tires? Thanks.
  5. SenorNoob

    Intake Crud

    Just wondering if this: [Larger] was normal or if I have another problem. The entire intake (throttle body to valves) looks like this. BTW, had it apart because of this: Thanks in advance.
  6. SenorNoob

    Code 172 CM & KOER

    I've been getting this code at first intermittently now constant (since the swap) as soon as the O2 sensor kicks in. Even when the check engine light is on I can connect a voltmeter to the O2 sensor and it reads a fairly steady 0.8. When first started it's at about 0.05 then starts climbing...
  7. SenorNoob

    '88 2.9 to 4.0 Questions

    I have an 88 Ranger 2.9, 4x4, Manual. I bought an engine from the "Auto Salvage" (Guy there made a point to correct me when I told my mom on the phone that I was at the junkyard.). It was supposed to be for a 92 Explorer. It had a tag that said 94 Ranger. Anyway I do have the 92 Explorer ECU...
  8. SenorNoob

    My newest addition

    Since I'm having trouble with the other truck but can't afford to have it not running for any amount of time to fix it and I really wanted a 4.0 4x4 anyway, I picked this up for a project truck. It's a '88, 2.9, 4x4. Supposedly, the transmission and transfer case have been rebuilt. It does have...
  9. SenorNoob

    '88 2.3 Compression Test Results

    Cylinder 1.......................... 135 Cylinder 2.......................... 135 Cylinder 3.......................... 80 (115 after some oil in the cylinder) Cylinder 3.......................... 140 This was done with the engine completely cold. I've also noticed a significant amount of air...
  10. SenorNoob

    HI!

    Just wanted to say hi now that I have an account. I've lurked for a while now. My truck wouldn't be running without all of the people here. Hopefully now I'll be able to help somebody. For the curious, only mods that I know of on my truck are 15" Jeep wheels and larger rear tires, a stereo, and...


Top