• Welcome Visitor! Please take a few seconds and Register for our forum. Even if you don't want to post, you can still 'Like' and react to posts.

Recent content by ReneGoFast


  1. Tranny misses shift, starter won’t engage?

    1998 Mazda B4000, 4.0 5 speed Auto trans. 160,000 miles, Pulling out into traffic, medium excelleration: trans shifts 1, 2, 3, Neutral!VROOM! Coasting along I Turn into drive of Gas Station, engine revs with pedal, no change in trans no matter what position i move shift lever, coasting into...
  2. 20th Anniversary Member Banner

    Geez, I’ve tipped waitresses more and got a lot less than what I’ve gotten here ! Well deserved, excellent use of $20.00 for sure. Thanks for all the fun. :headbang:
  3. Flashing OD light, no speedo, new VSS

    I have searched and read most everything I could find under "VSS". Flashing OD and speedometer not working, and have not found where anyone has actually fixed this problem. I have a 96 ranger XLT, 2wd 4.0 automatic ( 4r55e per the info on this forum) which had been running just fine, until the...
  4. 4.0 spark plug insulator inside engine!

    1996 ranger, 4.0, 2wd, auto. 237k. Tryin to chase down code P0304, misfire cyl 4. Bought new plugs, installed 3 on drivers side of engine. When I pulled plug #4there was NO insulator, no ceramic. It looks like it burnt off over time. gapped and installed new plug and started engine. There was...
  5. Joined to ask dumb questions

    Hello! I've been lurkin' around for quite sometime now. having read and used quite a lot of info off TRS to keep my Ranger running. I bought it with 149K on the odometer, it now reads 217K I'm guesssing it probably closer to 300K 'cause the odomerter gets stuck on .7 and just sits there for...


Top