Home Ford Ranger Forum Builders Guide How To Tech Other Articles Featured Rangers Readers Rangers Classifieds Shirts & Decals

Old 04-28-2013, 06:46 PM   #1
New Member
Join Date: Jul 2011
Posts: 3
Vehicle Year: 1999
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: I drive this thing Everywhere
Rep Power: 0
jljones87 is on a distinguished road
Default 99 Ranger running cold and no heat

I have spent the last six months trying to figure out what is going on my truck with it running cold, revving up randomly, and no heat. Well after replacing the idle air controller, thermostat, and numerous other things. Well this past week I managed to fix it all. My problem was an air pocket in the coolant. I opened up the radiator cap whn cold jacked up he right side and ran the truck for a good fifteen minutes and done. But that fixed the temp and rough idle. Today I flushed the heater core by un hooking the tubing a back flushing it with water. Now I have heat when it is almost summer. Just thought this might help someone since it fixed my problem and his site has helped tremendously.

Sent from my SPH-L710 using Tapatalk 2
jljones87 is offline   Reply With Quote
Advertisement - Don't want to see the forum ads? Click HERE to find out how to be a Premium Member.


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -5. The time now is 11:20 AM.

1999-2018 / 959 Media LLC / All Rights Reserved