Home Discussion Forum Tech Articles Other Articles Featured Rides Readers Rides Classifieds Shirts & Decals Parts Store

Ford Ranger Discussion Forum

Off-Road Truck Of The Month

'Rowdy Fitzgerald'
August 2014 OTOTM

Mini Truck Of The Month

'Flit-e' Dave'
August 2014 MTOTM
 
Old 09-13-2012, 10:15 PM   #1
Cricket
New Member
 
Join Date: Aug 2012
Posts: 24
Vehicle Year: 1990
Vehicle Make: Ford
Vehicle Model: Ranger XLT
Rep Power: 0
Cricket is on a distinguished road
Default coil pack problem

90 2.3 no spark on#2 and 3 passenger side coil pack, new wires,plugs coil pack.tested all-- ign.module ,wires, etc.did a spout test , inside cab got wet durring a tropicsl storm. truck wil run ,,<,like crap> engine light stays on cannot retrieve a code please help ,thanks
Cricket is offline   Reply With Quote
Forum Notices (Not shown to 'Premium Members')

 Reminder:

 We're looking for participants to help move our banner from Alaska to Florida: Click HERE.

 Click HERE to see the banner map.

 Want to become a Premium Member & not see these notices? Click HERE.

Want your truck considered for Truck Of The Month? Click HERE.

Don't forget to vote!

Old 09-13-2012, 10:21 PM   #2
Cricket
New Member
 
Join Date: Aug 2012
Posts: 24
Vehicle Year: 1990
Vehicle Make: Ford
Vehicle Model: Ranger XLT
Rep Power: 0
Cricket is on a distinguished road
Default

forgot to mention tachometer fluxuates on crickets ranger post
Cricket is offline   Reply With Quote
Old 09-14-2012, 03:08 PM   #3
FritzTKatt
Member
 
FritzTKatt's Avatar
 
Join Date: Mar 2012
Location: Camp Pendleton
Posts: 628
Vehicle Year: 94
Vehicle Make: Ford
Vehicle Model: Ranger XLT ext. cab
I use this vehicle for: high speed, low drag dust collection
Rep Power: 7
FritzTKatt will become famous soon enough
Default

Did you swap the coil packs out? Is possible you got a bad one from the store. It'll take 5 minutes and if it doesn't work, oh well. But if it does then you saved yourself quite a headache. If they are both "good" or bad, then you likely won't see a difference. Are your connections clean? Dielectric grease them, lightly.

I had a bad primary coil on my old truck (94 2.3) and swapped them out so it would run (to the store). Put the new one on the primary side and the old/good one back to the secondary.
__________________
4.0, 5 speed, warn 37780s, lockrite, 31x10.5 duratracs. Winch bumper, Warn M8000
FritzTKatt is offline   Reply With Quote
Old 09-14-2012, 09:57 PM   #4
Cricket
New Member
 
Join Date: Aug 2012
Posts: 24
Vehicle Year: 1990
Vehicle Make: Ford
Vehicle Model: Ranger XLT
Rep Power: 0
Cricket is on a distinguished road
Default Coil Pack Problem

Yes I swapped out coil packs & it made no difference. Forgot to mention that this problem happened due to driving through 3 ft. of water during Tropical storm. Had driven through water like this before & never had any problem.

Water came in the cab. I noticed water was around the computer housing & on the top.
Cricket is offline   Reply With Quote
Old 01-03-2013, 08:41 PM   #5
captanron
New Member
 
Join Date: Apr 2010
Posts: 6
Vehicle Year: 1991
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 0
captanron is on a distinguished road
Default coil packs

Quote:
Originally Posted by Cricket View Post
Yes I swapped out coil packs & it made no difference. Forgot to mention that this problem happened due to driving through 3 ft. of water during Tropical storm. Had driven through water like this before & never had any problem.

Water came in the cab. I noticed water was around the computer housing & on the top.
is there a difference between the coil packs?
captanron is offline   Reply With Quote
Old 01-12-2013, 07:58 AM   #6
PetesPonies
Member
 
Join Date: Jan 2008
Location: east coast
Posts: 1,103
Vehicle Year: 1984
Vehicle Make: Bronco II
Vehicle Model: V8
I use this vehicle for: fun
Rep Power: 17
PetesPonies has a spectacular aura aboutPetesPonies has a spectacular aura about
Default

No, there is no difference between the coil packs. Just that the right pack fires to start the engine, then both are operating.
__________________
Pete's Ponies
Mustang RUSToration & Performance
PetesPonies is offline   Reply With Quote
Old 01-15-2013, 06:08 PM   #7
logman7777
Junior Member
 
logman7777's Avatar
 
Join Date: Jul 2012
Location: South Western NJ
Posts: 54
Vehicle Year: 1995
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: Everything
Rep Power: 5
logman7777 is on a distinguished road
Send a message via Yahoo to logman7777
Default

Just for giggles disconnect your negative battery terminal then unplug your brain then either spray connector and CPU liberally with wire dry or use compressed air to blow any moisture from the connector and/ or the CPU box. You may have some stray water shorting out some signals in a best case scenario. worst case you are chasing through your electrical system or replacing the brain.. GOOD LUCK either way..
logman7777 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -5. The time now is 08:34 PM.




1999-2014 / 959 Media LLC / All Rights Reserved