Home Discussion Forum Tech Articles Other Articles Featured Rides Readers Rides Classifieds Shirts & Decals Parts Store

Ford Ranger Discussion Forum

Off-Road Truck Of The Month

'Rowdy Fitzgerald'
August 2014 OTOTM

Mini Truck Of The Month

'Flit-e' Dave'
August 2014 MTOTM
 
Old 09-12-2011, 08:49 PM   #1
Ranger22danger
New Member
 
Join Date: Aug 2011
Posts: 7
Vehicle Year: 1994
Vehicle Make: Ford
Vehicle Model: Ranger 2wd 2.3ltr
Rep Power: 0
Ranger22danger is on a distinguished road
Default Wont start but turns over!!

so got a question i have a 1994 ford ranger 2wd 2.3 litre and it is turning over but not starting... Would that be eletric ignition or my coil packs?
I just replaced the timing belt, water pump, and all the top end gaskets. The timing marks are spot on so it is not my timing. It is not getting any spark... I need help cause i am stumped it seems like this thing has ghosts in it hahaha!
Ranger22danger is offline   Reply With Quote
Forum Notices (Not shown to 'Premium Members')

 Reminder:

 We're looking for participants to help move our banner from Alaska to Florida: Click HERE.

 Click HERE to see the banner map.

 Want to become a Premium Member & not see these notices? Click HERE.

Want your truck considered for Truck Of The Month? Click HERE.

Don't forget to vote!

Old 09-13-2011, 05:14 PM   #2
Plum Ranger XLT
Member
 
Join Date: Aug 2007
Location: Lawrenceburg, IN
Posts: 302
Vehicle Year: 2008
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: Daily Transportation
Rep Power: 15
Plum Ranger XLT is on a distinguished road
Default

Possible coil packs or fuel pump went out.
__________________
2008 Ranger 2.3L DOHC 4 cylinder 5 speed and will only own Ford!
Plum Ranger XLT is offline   Reply With Quote
Old 09-13-2011, 05:39 PM   #3
Cadger
Junior Member
 
Cadger's Avatar
 
Join Date: Sep 2011
Location: Georgetown, ON
Posts: 30
Vehicle Year: 1994
Vehicle Make: ford
Vehicle Model: ranger
I use this vehicle for: driving, moving scrap, fun!
Rep Power: 7
Cadger is on a distinguished road
Send a message via MSN to Cadger Send a message via Skype™ to Cadger
Default

If it's not getting any spark, make sure you have your crank sensor plugged in. The coils won't fire without a crank reference.
__________________
'94 ranger XL 4x4 ext cab, running 32/11.5r15 on factory rims, 2" lift blocks, and nothin else really! OH! it's PURPLE!
Purple POWER!
Cadger is offline   Reply With Quote
Old 09-13-2011, 05:59 PM   #4
cody93
Member
 
cody93's Avatar
 
Join Date: Mar 2010
Location: Duluth GA
Posts: 1,841
Vehicle Year: 1987,1987
Vehicle Make: FORD, duh
Vehicle Model: rANGER x2
I use this vehicle for: scaring yuppies on the interstate
Rep Power: 23
cody93 has much to be proud ofcody93 has much to be proud ofcody93 has much to be proud ofcody93 has much to be proud ofcody93 has much to be proud ofcody93 has much to be proud ofcody93 has much to be proud ofcody93 has much to be proud of
Default

yea, i agree with the CPS being off, especially since timing belt work was done.
__________________
Quote:
Originally Posted by gwaii View Post
anything will fit.i have a sawzall and a welder.
Quote:
Originally Posted by AllanD View Post
Once upon a time it was financially practical to ship dirty laundry to China to have it washed rather than wash it in San Francisco.
cody93 is offline   Reply With Quote
Old 09-13-2011, 11:51 PM   #5
scotts90ranger
Member
 
scotts90ranger's Avatar
 
Join Date: Feb 2001
Location: Salem Oregon
Posts: 2,958
Vehicle Year: 1990
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: holding down the driveway
Rep Power: 35
scotts90ranger is a jewel in the roughscotts90ranger is a jewel in the roughscotts90ranger is a jewel in the rough
Default

if it's a california model with a cam sensor and you didn't keep the auxiliary shaft aligned that could do it too...

so it was running fine and you replaced those parts and now it suddenly doesn't start? Sounds like something got unplugged or something in the process...
__________________
converted to 4x4, turbo'd the 2.3, 6" lift with 35's and 5.13 gears!
Send e-mail instead of PM, box full...
scotts90ranger is offline   Reply With Quote
Old 09-14-2011, 01:13 AM   #6
Bryan22
Member
 
Bryan22's Avatar
 
Join Date: May 2008
Location: So-Cal babay
Posts: 1,611
Vehicle Year: 94 extd
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: fun, dd.
Rep Power: 16
Bryan22 is on a distinguished road
Default

Cam sensor shouldnt keep it from starting, but you can unplugg it to be sure(If it's a cali model). definitely make sure all 3 screws are in the ICM, the crank sensor it plugged in and not damaged, and that all conections are good to the ICM and coil packs... Good luck.
Bryan22 is offline   Reply With Quote
Old 09-15-2011, 04:34 PM   #7
Ranger22danger
New Member
 
Join Date: Aug 2011
Posts: 7
Vehicle Year: 1994
Vehicle Make: Ford
Vehicle Model: Ranger 2wd 2.3ltr
Rep Power: 0
Ranger22danger is on a distinguished road
Default

I think this truck has ghosts because right before i bought it from my dad he had just dumped like 800 bucks into it because it started to run funny and so he took it to the shop and while the mechanic was looking at it. the truck just dies and they couldnt get it running for two weeks. And the other day i was driving down the road at 55 mph and it just died on me. I pulled to the side of the road turned the key off and then fired it back up. then about a week later it I went to a friends house it was driving great no problems, and that was the last time i have got to drive it well unless you count towing it like 20 miles so i could get it home. So i think i am going to just buy a 4.0 carburated motor and not worry about it no more
Thank you guys for all the answer
Ranger22danger is offline   Reply With Quote
Old 09-16-2011, 12:50 AM   #8
Bryan22
Member
 
Bryan22's Avatar
 
Join Date: May 2008
Location: So-Cal babay
Posts: 1,611
Vehicle Year: 94 extd
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: fun, dd.
Rep Power: 16
Bryan22 is on a distinguished road
Default

you should just fix the problem and drive it for another 100k miles. Nothing is that complicated really. Shit, for $800 bux I could just guess an answer by replacing parts... thats nuts.
Bryan22 is offline   Reply With Quote
Old 09-16-2011, 03:07 AM   #9
ChargerOnDavins
Member
 
ChargerOnDavins's Avatar
 
Join Date: Jun 2010
Posts: 112
Vehicle Year: two 2003, 1 200
Vehicle Make: 3 Ford & 1 Dodg
Vehicle Model: Ranger, Explorer, Charger
Rep Power: 9
ChargerOnDavins is on a distinguished road
Default

Fuel pump - one of fords weak points. Still rather own 1 ford to 5 chevy or 10 dodge.
ChargerOnDavins is offline   Reply With Quote
Old 09-16-2011, 01:53 PM   #10
modelageek
Member
 
modelageek's Avatar
 
Join Date: Jan 2009
Location: Boston, MA
Posts: 2,113
Vehicle Year: 2004
Vehicle Make: Ford
Vehicle Model: Ext Cab, Edge, 2WD, M5OD, 4WABS, AC, 112k.
Rep Power: 16
modelageek will become famous soon enough
Default

Quote:
Originally Posted by Ranger22danger View Post
I think this truck has ghosts because right before i bought it from my dad he had just dumped like 800 bucks into it because it started to run funny and so he took it to the shop and while the mechanic was looking at it. the truck just dies and they couldnt get it running for two weeks. And the other day i was driving down the road at 55 mph and it just died on me. I pulled to the side of the road turned the key off and then fired it back up. then about a week later it I went to a friends house it was driving great no problems, and that was the last time i have got to drive it well unless you count towing it like 20 miles so i could get it home. So i think i am going to just buy a 4.0 carburated motor and not worry about it no more
Thank you guys for all the answer
Quote:
Originally Posted by Bryan22 View Post
you should just fix the problem and drive it for another 100k miles. Nothing is that complicated really. Shit, for $800 bux I could just guess an answer by replacing parts... thats nuts.
-if it it's a cali model it should have an obd-ii port and no ICM
-these trucks are pretty simple, if you are not able to figure it out i doubt very much you would have the skills to drop in a carbed 4.0 and get it running.
-I am confused about whether it ever ran after the TB install
-I am confused if you have spark or not........next time this happens determine if you have spark and or fuel
-I am not sure what they were doing for 2 weeks maybe they were using as a free parts delivery truck. I am a back yard mechanic and I bet I would have this figured out in less than an hour.
-relay? key cylinder? ignition switch?
-any CEL or pending codes?
__________________
2004 Ford Ranger Edge, ext cab, 2wd, 3.0, 5 speed, 112,000, AC. (For Sale)

Current project: 2004 Ext Cab, 4WD, 4.0, Auto, 135k(purchase price $1,350)needs an engine. I think a timing chain skipped. No rust or dents, needs a compound.

1999 Ford Ranger, Reg Cab, 2.5, 5 speed, 2WD, no AC, 150k (SOLD)

Last edited by modelageek; 09-16-2011 at 02:12 PM.
modelageek is online now   Reply With Quote
Reply

Bookmarks

Tags
1994 ranger 2.3 litre

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -5. The time now is 07:26 AM.




1999-2014 / 959 Media LLC / All Rights Reserved