Home Ford Ranger Forum Builders Guide How To Tech Other Articles Featured Rangers Readers Rangers Classifieds Shirts & Decals

 
Prev Previous Post   Next Post Next
Old 09-07-2010, 10:11 PM   #1
prerunin13
New Member
 
prerunin13's Avatar
 
Join Date: Aug 2008
Location: Oregon
Posts: 23
Vehicle Year: 2000
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: Sitting in the garage until the noise goes away
Rep Power: 0
prerunin13 is on a distinguished road
Default Squealing/Chirping/Whirring

Hi, I have a 2000 Ford Ranger 3.0 V6. I have a terrible squealing/chirping sound. I have replaced the cam synch and cam sensor, throw out bearing, slave cylinder, motor has been removed and completely gone through with new seals and new bearings. Still makes the same noise.

I have removed the serpentine belt - same noise. I have lubed the daylights out of the cam synch and also put in another one to make sure the new one I bought wasn't faulty out of the box - same noise. Ran it without the tranny hooked up - same noise. Any ideas? I'd hate to have to drive it off a cliff, but the idea is becoming more and more attractive each day.

Thanks!
__________________
Ya a 2WD goes just fine in the dunes, is your quad 4 wheel?
prerunin13 is offline   Reply With Quote
Advertisement - Don't want to see the forum ads? Click HERE to find out how to be a Premium Member.

5% Rock Auto Discount Code: 83E98FB3D89C78 Expires: June 26, 2018
 

Bookmarks





Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -5. The time now is 11:10 PM.




1999-2018 / 959 Media LLC / All Rights Reserved