Home Ford Ranger Forum Builders Guide How To Tech Other Articles Featured Rangers Readers Rangers Classifieds Shirts & Decals

 

Go Back   The Ranger Station Forums > Help Forums - Engine & Transmission Forums > V6 Forums > 2.9 Liter Forum

Notices

Reply
 
Thread Tools Display Modes
Old 09-15-2018, 12:15 PM   #1
lvwill
Member
 
lvwill's Avatar
 
Join Date: Sep 2013
Location: Las Vegas Nv.
Posts: 173
Vehicle Year: 1992
Vehicle Make: ford
Vehicle Model: ranger
I use this vehicle for: stress control
Rep Power: 11
lvwill is on a distinguished road
Default Started pinging

Not sure what's going on with this. Replaced the dizzy a couple years ago due to a bad bearing. Don't drive the truck awhole lot maybe 4000 miles a year. All of a sudden it goes from running great to seriously pinging at any throttle position. No cell or any other problems. Was going to check timing, unplugged spout connecter and it was to hot to do anything else and basically forgot about it. Been driving it around for a week here and there with spout out and it seems to be fine but guttless. Plugged it back in and it started to ping again.
Anyone have any idea what I should be looking for?
This basically started overnight.

Thanks in advance for any help
William
lvwill is offline   Reply With Quote
Advertisement - Don't want to see the forum ads? Click HERE to find out how to be a Supporting Member.


5% Rock Auto Discount Code: 20B2FF503DCF74 Expires: September 28, 2018
Old 09-15-2018, 12:33 PM   #2
RonD
Member
 
Join Date: Jun 2012
Location: canada
Posts: 11,863
Vehicle Year: 1994
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 53
RonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant future
Default

The SPOUT is the same as the Vacuum Advance was on a distributor, it was/is used to retard or advance spark based on engine Load.

So yes gutless without spark advance under load, RPM advance is still working, TFI module does that on its own, so engine can run just not as well.
Computer has engine load data so sends out retard and advance info to TFI module on that SPOUT wire

So did you check the base spark timing?
10-12 BTDC is popular choice for the 2.9l
This needs to be done first


Started overnight.
What about gasoline last added to the tank, all gasoline has water in it, and that water settles to the bottom of the gas tank when vehicle sits.
If last gasoline added had a bit more water than "normal", then you get a lean mix and pinging
HEET or Octane Boost is ethanol, ethanol can bond with water, gasoline can't, so it can help get rid of any water in the tank without the pinging

Last edited by RonD; 09-15-2018 at 12:38 PM.
RonD is offline   Reply With Quote
Old 09-15-2018, 12:46 PM   #3
lvwill
Member
 
lvwill's Avatar
 
Join Date: Sep 2013
Location: Las Vegas Nv.
Posts: 173
Vehicle Year: 1992
Vehicle Make: ford
Vehicle Model: ranger
I use this vehicle for: stress control
Rep Power: 11
lvwill is on a distinguished road
Default

I did set timing at 12 btdc when I put in the new distributor. I will check it out either tonight or in the morning. Not sure how it could have changed on it's own though. I've been putting premium in it ever since this happened. Forgot about the spout until this morning when I found it on the work bench.
I know this sounds stupid but at the moment the truck is my DD. I only drive it 22 miles a day but i need it until y b2 is done.
lvwill is offline   Reply With Quote
Old 09-15-2018, 02:39 PM   #4
RonD
Member
 
Join Date: Jun 2012
Location: canada
Posts: 11,863
Vehicle Year: 1994
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 53
RonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant future
Default

Distributor could have shifted, or sensor inside did, even TFI module could have an issue.
Looking at base timing would be where to start, just to take that off the table.

Then we can start GUESSING about other reasons for the pinging

Last edited by RonD; 09-15-2018 at 03:00 PM.
RonD is offline   Reply With Quote
Reply

Bookmarks





Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2.8 Pinging... rangerin 2.8 Liter Forum 3 12-27-2013 08:29 PM
4.0L Pinging ScottB 4.0 Liter Forum 4 05-03-2013 12:09 PM
Pinging! chuck ray 4-Cylinder (2000 & Older) 1 04-21-2013 03:17 PM
3.0 pinging Lonewolf 3.0 Liter Forum 4 01-10-2010 06:24 PM
pinging 3.0 fordboi415 3.0 Liter Forum 21 11-15-2009 07:40 PM




All times are GMT -5. The time now is 12:38 AM.




© 1999-2018 / 959 Media LLC / All Rights Reserved