Home Ford Ranger Forum Tech Articles Other Articles Featured Rangers Readers Rangers Classifieds Shirts & Decals Parts Store

Ford Ranger Discussion Forum  

Go Back   The Ranger Station Forums > Help Forums - Styling & Electrical > Misc Electrical & Gauges

Misc Electrical & Gauges Post your speedometer, gauges, interior and non audio/video questions here.

Reply
 
Thread Tools Display Modes
Old 08-07-2007, 06:12 PM   #1
86isuzu
TRS Member Since 2003


 
86isuzu's Avatar
 
Join Date: Aug 2007
Location: Orchard Park, NY
Posts: 375
Vehicle Year: 1989
Vehicle Make: Ford
Vehicle Model: Bronco II
I use this vehicle for: projects
Rep Power: 21
86isuzu will become famous soon enough
Send a message via AIM to 86isuzu
Question power windows dont work

hey i got a 95 ranger reg cab. my drivers side power window wont go up. it was working fine, then suddenly it doesnt. right now its stuck completely inside the door. fuse is fine. determined switch was not the problem. got the whole door panel apart. ive got the regulator soakin in pb blaster, so hopefully i can muscle the window up for now. im figurin its the motor. any1 got any ideas to just get the window up? even just temporary? ill spend the 180 bucks for a motor later. wtf?:confused:
__________________
2000 Ford Ranger 3.0L Sold :(
2001 Saturn SL2 - commuter
1989 Ford Bronco II - Fresh paint job
2003 Ford Ranger XL 2wd - only 36k miles!
Quote:
Originally Posted by LittleBigFoot View Post
Put fish under his hubcaps.
No one ever checks for fish in the hubcaps.
86isuzu is offline   Reply With Quote
Forum Notices (Not shown to 'Premium Members')

 SPRING ONLINE MAGAZINE!

 Check out the latest articles

 Want to become a Premium Member & not see these notices? Click HERE.

Old 08-07-2007, 06:35 PM   #2
Joe_Roofer
Member
 
Joe_Roofer's Avatar
 
Join Date: Aug 2007
Location: Berkshires, MA
Posts: 182
Vehicle Year: 1990ish
Vehicle Make: Ford
Vehicle Model: Ranger
I use this vehicle for: playin'
Rep Power: 21
Joe_Roofer is on a distinguished road
Default

I had the same problem, mine wasn't all the way down and I could just pull it up.
I stuck a chunk of 2x4 in the door so it couldn't be pushed all the way down and greased everything so it goes up and down real smooth.
Wait, did I say I HAD that problem?
Its the passenger side on mine. I'll fix it some day.
Good luck
__________________
1990 Ranger, '96 bed, 3" body lift, Belltech 6400's, 2" coil spacers, BFG 31's, Warn manual hubs, C-clip eliminator, Powertraxx no slip rear locker & XRC8 winch.

Quote:
Originally Posted by gwaii View Post
not photoshop....sawzall
Joe_Roofer is offline   Reply With Quote
Old 08-07-2007, 08:43 PM   #3
Wicked_Sludge
Member
 
Wicked_Sludge's Avatar
 
Join Date: Aug 2007
Location: Westport, WA
Posts: 6,937
Vehicle Year: 1993
Vehicle Make: Ford
Vehicle Model: Ranger, Flareside
I use this vehicle for: Attracting the ladies
Rep Power: 36
Wicked_Sludge is a jewel in the roughWicked_Sludge is a jewel in the roughWicked_Sludge is a jewel in the rough
Send a message via MSN to Wicked_Sludge
Default

try pulling up on the window while pushing the button....might be enough to help a stuck or weak motor.

i'd pull the plug off the motor and check for voltage with a meter. if you get 12v, then its the motor. if not, then you have other electrical issues.
__________________
As seen on the internets!

Quote:
Originally Posted by Hahnsb2 View Post
Dyno sheet or GTFO
Quote:
Originally Posted by Ranger Dave (B25) View Post
The call was for scantily-clad women. A Certificate of Boob Authenticity was NOT specified.
Quote:
Originally Posted by Grant Imahara
I'm not sure if we have the right stuff; I'm just hoping we don't have the wrong stuff.
__________________________________________________ ____________________________________
Last edited by Wicked_Sludge : Today at 09:16 PM.
Wicked_Sludge is offline   Reply With Quote
Old 08-08-2007, 12:45 AM   #4
team_insanity
New Member
 
Join Date: Aug 2007
Posts: 7
Vehicle Year: 2002
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 0
team_insanity is on a distinguished road
Send a message via Yahoo to team_insanity
Default

double check that switch. I just had both of mine go out and I had determined they were good with a voltmeter. When the pax side went out, I decided to try the switches first on a whim (and cause I'm cheap) and that fixed the problems.
__________________
The User Formerly Known As rentalguy1

http://www.teaminsanity.us
team_insanity is offline   Reply With Quote
Old 08-08-2007, 01:20 AM   #5
beyonder
Junior Member
 
beyonder's Avatar
 
Join Date: Aug 2007
Posts: 36
Rep Power: 21
beyonder is on a distinguished road
Default

have you tried applying voltage to the motor? you may be able to get the window back up that way. The motor I have are a simple 2 wire connection they use the reversed polarity to roll the windows up. They're not from a ranger though so I'm unsure if the ranger ones are the same. ( they came from a caravan ). If you apply power to the motor and it works I'd lay odds that your switches are hooped. I don't have ford swiches either so I'm unsure on they're wirring, however the ones I have came from canadian tire, paid like 15.00 ea or something for them. Might get you through till you can get ford switches ( I'm assuming they're probably pretty expensive ).
beyonder is offline   Reply With Quote
Old 08-09-2007, 08:49 PM   #6
86isuzu
TRS Member Since 2003


 
86isuzu's Avatar
 
Join Date: Aug 2007
Location: Orchard Park, NY
Posts: 375
Vehicle Year: 1989
Vehicle Make: Ford
Vehicle Model: Bronco II
I use this vehicle for: projects
Rep Power: 21
86isuzu will become famous soon enough
Send a message via AIM to 86isuzu
Default

Quote:
Originally Posted by Wicked_Sludge View Post
try pulling up on the window while pushing the button....might be enough to help a stuck or weak motor.
tried it. i was hopin, but o well.

I started playin with it again and now i hear a click under the dash by the steering column. screw it ill take it to a shop around here.
__________________
2000 Ford Ranger 3.0L Sold :(
2001 Saturn SL2 - commuter
1989 Ford Bronco II - Fresh paint job
2003 Ford Ranger XL 2wd - only 36k miles!
Quote:
Originally Posted by LittleBigFoot View Post
Put fish under his hubcaps.
No one ever checks for fish in the hubcaps.
86isuzu is offline   Reply With Quote
Old 08-09-2007, 09:07 PM   #7
94STXRanger
Member
 
94STXRanger's Avatar
 
Join Date: Aug 2007
Location: Kansas City
Posts: 768
Vehicle Year: 1994,1965
Vehicle Make: Ford
Vehicle Model: Ranger supercab, Mustang Coupe
Rep Power: 22
94STXRanger is on a distinguished road
Send a message via AIM to 94STXRanger
Default

I had the same problem with my 94, in the rain. I was lookin at it and had the panel off and disconnected the motor. Later i reconnected it and jiggled a bit and it worked. I guess try that if you havent.
94STXRanger is offline   Reply With Quote
Old 08-09-2007, 10:24 PM   #8
Jeepman401
Junior Member
 
Jeepman401's Avatar
 
Join Date: Aug 2007
Location: CT
Posts: 72
Rep Power: 21
Jeepman401 is on a distinguished road
Default

If you have a bit of spare time, swap the motors from side to side, that will at least get you a working drivers window
__________________
1992 ranger 4.0 4wd- in surgery
1999 jeep cherokee sport- the new daily driver
Jeepman401 is offline   Reply With Quote
Old 08-09-2007, 10:27 PM   #9
martin
Member
 
Join Date: Aug 2007
Location: St Bruno, Quebec
Posts: 3,220
Vehicle Year: 1984 1991
Vehicle Make: ford
Vehicle Model: b2 explorer
Rep Power: 30
martin is just really nicemartin is just really nicemartin is just really nicemartin is just really nice
Default

Don't know about the later window motors but the earlier ones used to have a thermal contact switch inside, the contacts get oxidised, clean the contacts and they work fine until next time. did you try giving the motor a whack with something heavy?
martin is offline   Reply With Quote
Old 08-10-2007, 10:19 AM   #10
team_insanity
New Member
 
Join Date: Aug 2007
Posts: 7
Vehicle Year: 2002
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 0
team_insanity is on a distinguished road
Send a message via Yahoo to team_insanity
Default

Quote:
Originally Posted by 86isuzu View Post
tried it. i was hopin, but o well.

I started playin with it again and now i hear a click under the dash by the steering column. screw it ill take it to a shop around here.
Dude, I'm telling ya...I just went through the exact same problem 2 weeks ago with my '02. Go to the dealership and get switches for both sides. It should be about $50-$60 total. Both of mine went out at the exact same time for some reason. BTW...the click under the dash is the relay...which if you check, will be good also.
__________________
The User Formerly Known As rentalguy1

http://www.teaminsanity.us
team_insanity is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -5. The time now is 08:10 PM.




1999-2014 / 959 Media LLC / All Rights Reserved