Home Ford Ranger Forum Tech Articles Other Articles Featured Rangers Readers Rangers Classifieds Shirts & Decals Parts Store

Ford Ranger Discussion Forum  

Go Back   The Ranger Station Forums > Help Forums - Engine & Transmission Forums > V6 Forums > 3.0 Liter Forum

Reply
 
Thread Tools Display Modes
Old 10-25-2017, 06:45 PM   #1
98v70dad
New Member
 
Join Date: Oct 2017
Posts: 25
Vehicle Year: 1996
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 1
98v70dad is on a distinguished road
Default 96 with code P1443 help needed

My dad gave me his 96 ranger XLT with 49,000 miles on it. He has had trouble code P1443 since 1998 but he lives in an area with no emission check so he let it ride. His fix was a piece of black electrical tape over the check engine light.

Anyhow, I'm in Atlanta and I can't register the truck in Georgia until I fix this. I have troubleshot evap systems before and know what a pain they can be to diagnose. My 20 year old volvo has had this same problem - major PITA.

Since the code showed up when the truck was only 2 years old I'm thinking that may be a hint. The code indicates its an evap system control valve but I know that it could also be a gas cap or a leak.

Can anyone tell me where that valve is located and what the most likely source of the problem could be considering that it showed up when the truck was nearly new.
98v70dad is online now   Reply With Quote
Forum Notices (Not shown to 'Premium Members')

 SPRING ONLINE MAGAZINE!

 Check out the latest articles

 Want to become a Premium Member & not see these notices? Click HERE.

Old 10-26-2017, 02:46 PM   #2
RonD
Member
 
Join Date: Jun 2012
Posts: 10,587
Vehicle Year: 1994
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 47
RonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant future
Default

Some good info in this thread: http://www.therangerstation.com/foru...ad.php?t=70038

The codes the computer does NOT choose to use are as important as the one it does use.

OBD2 codes here: http://www.therangerstation.com/tech...II_codes.shtml

Computer used P1443 and not :
P1440 Purge Valve Stuck Open
P1441 ELC System 1
P1442 Evaporative Emission System Control Leak Detected
(P1443 Evaporative Emission System Control Valve (low/no flow))
P1444 Evaporative Emission System Purge Flow Sensor Circuit Low Input
P1445 Purge Flow Sensor Circuit High Input
P1446 Evaporative Vacuum Solenoid Circuit
P1447 ELC System Closure Valve Flow
P1448 ELC System 2
P1449 Evaporative Check Solenoid Circuit
P1450 Unable to Bleed Up Fuel Tank Vacuum
P1451 Evap Emission Control System Vent Control Circuit
P1452 Unable to Bleed Up Fuel Tank Vacuum
P1453 Fuel Tank Pressure Relief Valve Malfunction
P1454 Evaporative Emission System Vacuum Test
P1455 Evaporative Emission Control System Control Leak (gross leak/no flow)
P1456 Fuel Tank Temperature Sensor Circuit
P1457 Unable To Pull Fuel Tank Vacuum

So probably not a gas cap or filler hose issue

Find and check connection on Purge valve, then test hoses on purge valve
Pressure sensor could be at fault

When you get any code it is always good to check the other codes computer could have used for that system, helps eliminate other parts
RonD is offline   Reply With Quote
Old 10-26-2017, 08:58 PM   #3
98v70dad
New Member
 
Join Date: Oct 2017
Posts: 25
Vehicle Year: 1996
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 1
98v70dad is on a distinguished road
Default

Quote:
Originally Posted by RonD View Post
Some good info in this thread: http://www.therangerstation.com/foru...ad.php?t=70038

The codes the computer does NOT choose to use are as important as the one it does use.

OBD2 codes here: http://www.therangerstation.com/tech...II_codes.shtml

Computer used P1443 and not :
P1440 Purge Valve Stuck Open
P1441 ELC System 1
P1442 Evaporative Emission System Control Leak Detected
(P1443 Evaporative Emission System Control Valve (low/no flow))
P1444 Evaporative Emission System Purge Flow Sensor Circuit Low Input
P1445 Purge Flow Sensor Circuit High Input
P1446 Evaporative Vacuum Solenoid Circuit
P1447 ELC System Closure Valve Flow
P1448 ELC System 2
P1449 Evaporative Check Solenoid Circuit
P1450 Unable to Bleed Up Fuel Tank Vacuum
P1451 Evap Emission Control System Vent Control Circuit
P1452 Unable to Bleed Up Fuel Tank Vacuum
P1453 Fuel Tank Pressure Relief Valve Malfunction
P1454 Evaporative Emission System Vacuum Test
P1455 Evaporative Emission Control System Control Leak (gross leak/no flow)
P1456 Fuel Tank Temperature Sensor Circuit
P1457 Unable To Pull Fuel Tank Vacuum

So probably not a gas cap or filler hose issue

Find and check connection on Purge valve, then test hoses on purge valve
Pressure sensor could be at fault

When you get any code it is always good to check the other codes computer could have used for that system, helps eliminate other parts
Good advice. I've never thought to do that. I don't get much from your prssure sensor comment though. Is the pressure sensor in the purge valve or is it a separate part?
98v70dad is online now   Reply With Quote
Old 10-27-2017, 05:16 PM   #4
RonD
Member
 
Join Date: Jun 2012
Posts: 10,587
Vehicle Year: 1994
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 47
RonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant future
Default

Not sure where it is in a 1996

EVAP Pressure sensor tells the computer if tank is holding pressure and if pressure is being released during Purge, by purge valve

It will be between purge valve and charcoal canister or on the gas tank
Never ran across one under the truck
RonD is offline   Reply With Quote
Old 11-01-2017, 09:39 AM   #5
98v70dad
New Member
 
Join Date: Oct 2017
Posts: 25
Vehicle Year: 1996
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 1
98v70dad is on a distinguished road
Default

Quote:
Originally Posted by 98v70dad View Post
My dad gave me his 96 ranger XLT with 49,000 miles on it. He has had trouble code P1443 since 1998 but he lives in an area with no emission check so he let it ride. His fix was a piece of black electrical tape over the check engine light.

Anyhow, I'm in Atlanta and I can't register the truck in Georgia until I fix this. I have troubleshot evap systems before and know what a pain they can be to diagnose. My 20 year old volvo has had this same problem - major PITA.

Since the code showed up when the truck was only 2 years old I'm thinking that may be a hint. The code indicates its an evap system control valve but I know that it could also be a gas cap or a leak.

Can anyone tell me where that valve is located and what the most likely source of the problem could be considering that it showed up when the truck was nearly new.
I replaced the purge valve and that fixed it. Oddly the price for Chinese knock offs at auto parts stores was around $70. I found a new FoMOCo part in a sealed bag for $43 on Amazon with free shipping. It pays to look around!
98v70dad is online now   Reply With Quote
Old 11-01-2017, 11:01 AM   #6
RonD
Member
 
Join Date: Jun 2012
Posts: 10,587
Vehicle Year: 1994
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 47
RonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant futureRonD has a brilliant future
Default

Good work

Thanks for the update and fix for the code
RonD is offline   Reply With Quote
Old 11-01-2017, 06:41 PM   #7
98v70dad
New Member
 
Join Date: Oct 2017
Posts: 25
Vehicle Year: 1996
Vehicle Make: Ford
Vehicle Model: Ranger
Rep Power: 1
98v70dad is on a distinguished road
Default

Quote:
Originally Posted by RonD View Post
Good work

Thanks for the update and fix for the code
Unfortunately I was too optimistic. I made it 40 miles to work code free but it returned on the way home tonight. I hate emission control system problems.

Its possible that the hose from the manifold to the thermister is pinched. The hose looks like its bent quite a bit and its separated from the tubing routing hardware meant to prevent that. I'll check it later in the week.

The first two times I got a similar code on my 20 year old volvo it was the purge valve. Getting rid of the code on the volvo the third time eventually involved replacing everything in the system. Hopefully that won't happen here.
98v70dad is online now   Reply With Quote
Old 11-10-2017, 05:49 PM   #8
OnAll4s
New Member
 
Join Date: Nov 2017
Posts: 4
Vehicle Year: 1995
Vehicle Make: Ford Ranger
Vehicle Model: XLT 4x4
Rep Power: 0
OnAll4s is on a distinguished road
Default

Had the same problem replaced the valve and the solenoid that go after the charcoal canister. They are connected by a vacc hose and it has been good since
OnAll4s is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble code p1443 Fane 4.0 Liter Forum 3 05-19-2015 10:35 AM
p1443 code?? 97Ranger_XLT 4.0 Liter Forum 6 01-23-2011 10:19 AM
96 Ranger P1443 Error Code Help acleme1 General Discussions 2 09-22-2010 08:17 PM
Pulled code p1443 colby450xc General Discussions 5 08-07-2010 04:37 PM
p1443 code iam STUMPED!!! Destroyer000 General Discussions 14 01-03-2008 11:50 PM




All times are GMT -5. The time now is 10:38 PM.




1999-2014 / 959 Media LLC / All Rights Reserved