Search results


  1. cbxer55

    Weird charging anomaly?

    Been noting an odd occurrence on my 98 Ranger. When just putting around, the volt gauge appears normal. When getting into the throttle, at a certain rpm, the volt gauge suddenly drops and, if at night, the lights dim. Last time I was on the highway with it, at around 85 mph, the same occurs...
  2. cbxer55

    Wonderin about something!

    Was in a large empty parking lot today, and did some burnouts for the heck of it. Every time, left two long black tracks on the dry ground. Truck has a 3.73 standard 7.5 axle. Always thought standard axles didn't leave two tracks. Thought one tire spun, while the other hooked. 1998 3.0 auto...
  3. cbxer55

    Odd happenings!

    Thought I had it all fixed. Now for some odd reason, the dang thing will just up and die while driving down the road. It's happened twice in the last few days. Driving down the road, and all of a sudden, the engine stalls and all the gauge lights come on. Coast to the side of the road, wait a...
  4. cbxer55

    Front sway bar end links

    For the last year, my Ranger has made a lot of racket on up-and-down movement. Thought it was the ball joints, but my tires are not wearing strange. Inspected everything, and found the front end link bolts protruding out the top of the sway bar almost two inches. There were some missing bushings...
  5. cbxer55

    Any Lightning owners here?

    Mine is a 2004 Oxford White bought from the original owner in 2009. Many mods done, including swapping the original serpentine belt for a cog drive with larger lower pulley to up boost. Entire intake from the plenum on top of the blower to the filter. Catback Borla stainless steel exhaust...
  6. cbxer55

    Here we go again!

    Hey folks, Haven't been here for a few years, since I have a 2004 Lightning as well. Still have my 98 3.0 V-6 Ranger. Been running pretty dang good lately, put a new fuel pump and filter in her in early December, computer has been clean ever since, no codes and all monitors in the ready...
  7. cbxer55

    Do 3.0 Rangers have dirty injector problems?

    For some time now I have been fighting an extremely irratating intermittent starting problem. Sometimes it fires right up, others I can crank and crank until the battery is dead with no firing. Later on it fires right up. I have replaced all the sensors, plugs, wires, coil pack to no avail. Out...
  8. cbxer55

    Intermittent crank, but no start.

    I have a 98 2wd Ranger automatic with 3.0 V6. It has aftermarket air intake, exhaust and JET chip on computer. Help! For awhile now, about a year, my truck has this annoying problem. Most days it will start right up and run beautifully. For instance I was out driving this morning and it ran...


Top